cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
peterjohn
Adventurer
Adventurer
525 Views
Registered: ‎10-18-2019

Issue in launching Petalinux

Jump to solution

Hi, 

I have installed Petalinux 2018.3 in Ubuntu 18.04 but I am not able to source the settings.sh file. 

How to fix the problem ? 

peter@peter:~$ source ~/opt/xilinx/Petalinux/settings.sh
PetaLinux environment set to '/home/peter/opt/xilinx/Petalinux'
WARNING: /bin/sh is not bash! 
bash is PetaLinux recommended shell. Please set your default shell to bash.
WARNING: This is not a supported OS
INFO: Checking free disk space
INFO: Checking installed tools
environment: line 311: ((: 10#15~1 > 10#3: syntax error in expression (error token is "~1 > 10#3")
environment: line 315: ((: 10#15~1 < 10#3: syntax error in expression (error token is "~1 < 10#3")
INFO: Checking installed development libraries
INFO: Checking network and other services
WARNING: No tftp server found - please refer to "PetaLinux SDK Installation Guide" for its impact and solution

 

0 Kudos
1 Solution

Accepted Solutions
patocarr
Teacher
Teacher
429 Views
Registered: ‎01-28-2008

Hi @peterjohn 

  You may want to change to bash by using this command

sudo dpkg-reconfigure dash

  After that, you may need to restart your login session before retrying with Petalinux.

 

Thanks,

-Pat

 

Give kudos if helpful. Accept as solution if it solves your problem.
https://tuxengineering.com/blog

View solution in original post

5 Replies
watari
Teacher
Teacher
519 Views
Registered: ‎06-16-2013

Hi @peterjohn 

 

Would you change default shell from dash to bash ?

 

This url is direct answer. But it's one of the solution.

Would you try it ?

 

https://www.xilinx.com/support/answers/60088.html

 

Best regards,

0 Kudos
peterjohn
Adventurer
Adventurer
515 Views
Registered: ‎10-18-2019

@watari , I don't have Vivado and SDK. I just have Petalinux 2018.3 in Ubuntu 18.04 in virtual machine. 

0 Kudos
watari
Teacher
Teacher
505 Views
Registered: ‎06-16-2013

Hi @peterjohn 

 

Would you change default shell from dash to bash on your Ubuntu ?

 

$ sudo rm /bin/sh

$ sudo ln -s /bin/bash /bin/sh

 

This solution is same as my previous URL.

Would you try it ?

 

Best regards,

0 Kudos
peterjohn
Adventurer
Adventurer
500 Views
Registered: ‎10-18-2019

I just run both commands. 

 

peter@peter:~$ sudo rm /bin/sh
[sudo] password for peter: 
peter@peter:~$ sudo ln -s /bin/bash /bin/sh
peter@peter:~$ source ~/opt/xilinx/Petalinux/settings.sh
PetaLinux environment set to '/home/peter/opt/xilinx/Petalinux'
WARNING: This is not a supported OS
INFO: Checking free disk space
INFO: Checking installed tools
environment: line 311: ((: 10#15~1 > 10#3: syntax error in expression (error token is "~1 > 10#3")
environment: line 315: ((: 10#15~1 < 10#3: syntax error in expression (error token is "~1 < 10#3")
INFO: Checking installed development libraries
INFO: Checking network and other services
WARNING: No tftp server found - please refer to "PetaLinux SDK Installation Guide" for its impact and solution

I still have environment error. I am also wondering about this warning "This is not a supported OS". 

0 Kudos
patocarr
Teacher
Teacher
430 Views
Registered: ‎01-28-2008

Hi @peterjohn 

  You may want to change to bash by using this command

sudo dpkg-reconfigure dash

  After that, you may need to restart your login session before retrying with Petalinux.

 

Thanks,

-Pat

 

Give kudos if helpful. Accept as solution if it solves your problem.
https://tuxengineering.com/blog

View solution in original post