UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor jonortega
Visitor
9,084 Views
Registered: ‎06-15-2015

Makefile error with ZEDBoard

Hi!

 

I'm a complete newbie onto Xilinx FPGAs.

I am starting to work with the ZEDBoard.

 

Following the first example, I define and configure the hardware system with Vivade IDE.

Then I try to create a software application with the SDK. I try to create an empty application, but I get errors in the Makefile:


make: *** [ps7_cortexa9_0/libsrc/devcfg_v3_2/src/make.libs] Error 2    LED_test_bsp             C/C++ Problem

It seems that there is some library that is not being loaded properly?

How can I fix it?

I have run the same system in another computer with no problem, but I am unable to make it run in my own.

 

Thanks in advance for your help.

 

 

 

 

Screenshot from 2015-06-15 14:32:06.png
0 Kudos
6 Replies
Xilinx Employee
Xilinx Employee
9,071 Views
Registered: ‎07-01-2010

Re: Makefile error with ZEDBoard

@jonortega

 

Are you using Ubunutu Machine ?

 

I think you may be missing some 32-bit libraries  and so you are seeing this issue.

 

Regards,

Achutha

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------
Visitor jonortega
Visitor
9,069 Views
Registered: ‎06-15-2015

Re: Makefile error with ZEDBoard

Thanks for your help achutha.

 

Nice guess: I am running Ubuntu on a 64 bits machine.

 

I have downloaded and installed  the Vivado Design Suite Full Product. 

How can I tell if it is choosing properly the 64 or 32 bits libraries?

 

In the project settings I can see that the default library is: xil_defaultlibVivado 32 64 bits

 

0 Kudos
Xilinx Employee
Xilinx Employee
9,053 Views
Registered: ‎08-02-2007

Re: Makefile error with ZEDBoard

hi,

 

which version of SDK have you installed? If it is 2015.1 then it only has 64-bit install version

 

--hem

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Visitor jonortega
Visitor
9,046 Views
Registered: ‎06-15-2015

Re: Makefile error with ZEDBoard

I have tried the latest one: 2015.1

And after testing it and finding this problem I have installed the 2014.4, which is the one that has been installed in another computer and works fine.

 

I get the same error with both versions.

 

Thanks for your help

0 Kudos
Xilinx Employee
Xilinx Employee
9,041 Views
Registered: ‎08-02-2007

Re: Makefile error with ZEDBoard

hi

 

can you type in the console,  make -v in both the working/failing machines?

 

if the versions do not match, then you might have to install the make version.

 

--hem

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Visitor jonortega
Visitor
9,037 Views
Registered: ‎06-15-2015

Re: Makefile error with ZEDBoard

Sure, here you have the version I get.

 

For the 2015.1:

 

GNU Make 4.0
Built for x86_64-pc-linux-gnu
Copyright (C) 1988-2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

 

 

For the 2014.4:

 

GNU Make 4.0
Built for x86_64-pc-linux-gnu
Copyright (C) 1988-2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

0 Kudos