cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
2,952 Views
Registered: ‎02-24-2014

Mask interrupts while debugging

Hi

 

I'd like to mask the interrupts of my MicroBlaze system while I step through my application code. The execution continually jumps to the ISR dispatcher which makes it hard to debug the rest of the code.

 

My setup consists of the following:

- Kintex7 with MicroBlaze conifgured

- SDK 2014.1

- TCF debug session connected via USB-JTAG to KC705 board

 

 

Can anyone help, pease?

 

Thanks

Chris

 

0 Kudos
2 Replies
Highlighted
Anonymous
Not applicable
2,930 Views

Re: Mask interrupts while debugging

You could set a breakpoint at the start of your application. in the Breakpoint, you can set an action. In the action you can call the xmd.exe with a tcl file that will write to the interrupt controller IER register to mask the interrupts out.

 

I have attached a doc showing how to set actions on breakpoints. For infor on the interrupt controller, you can see its datasheet

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
2,925 Views
Registered: ‎08-06-2007

Re: Mask interrupts while debugging

Hi,

 

Another way might be to disable interrupt in MicroBlaze in XMD.

 

MicroBlaze MSR register contains a IE bit (bit 30) which is set when MicroBlaze accept interrupts.

Just read the current value with

> rrd msr

change the value by setting bit 30 to '0' and write back the new value to MSR with

> rwr msr value

 

When you want to enable interrupts again, just repeat the above sequence but now set the IE bit to '1'.

 

Göran

 

 

0 Kudos