cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
ank_mistry
Contributor
Contributor
4,933 Views
Registered: ‎05-26-2014

Matching ADDRESS_SPACE for code segment #1 not found in 'sys tem_bd.bmm'.

Jump to solution

Hello All,

              I'm getting error when i try to generate the .bin file.check below the command and the error

 

 

          

C:\*****\****\*****\*****\BIN>data2mem -bm system_bd.bmm -bd system1.elf -bt system.bit

 

ERROR:Data2MEM:33 - Matching ADDRESS_SPACE for code segment #1 not found in 'sys
tem_bd.bmm'.
Code segment #1 occupies [0x48000000:0x48002703]turnV3Test.bit

 

  can i get any help on this!!!!!!

 

  Thanks 

0 Kudos
Reply
1 Solution

Accepted Solutions
Anonymous
Not applicable
5,328 Views

This error is saying that the data file (either MEM or ELF) oes not have any data that is specified in the address range in the BMM file.

 

You need to fix this by changing the BMM file, or the ELF file (linker), or the MEM file so the data is within this region

View solution in original post

0 Kudos
Reply
5 Replies
sampatd
Scholar
Scholar
4,930 Views
Registered: ‎09-05-2011
Please check the following AR to understand why this error occurs:
http://www.xilinx.com/support/answers/21121.html
0 Kudos
Reply
ank_mistry
Contributor
Contributor
4,918 Views
Registered: ‎05-26-2014

Thanks for the help.

 

I know the address map is not proper,but i then too want to add the .elf file. I even tried undating the linker script but that too didn't work.I will add the flash and try it out.

 

Any suggestion please do tell.

 

Thanks

0 Kudos
Reply
sha@hys
Explorer
Explorer
3,295 Views
Registered: ‎05-31-2015

Hi,

 

 Did you solve the problem??? I have a saturn V3 board and has same error with data2mem.

Tags (2)
0 Kudos
Reply
Anonymous
Not applicable
5,329 Views

This error is saying that the data file (either MEM or ELF) oes not have any data that is specified in the address range in the BMM file.

 

You need to fix this by changing the BMM file, or the ELF file (linker), or the MEM file so the data is within this region

View solution in original post

0 Kudos
Reply
ank_mistry
Contributor
Contributor
2,989 Views
Registered: ‎05-26-2014

Hi,

 

Yes, I did rebuild the project and updated the linker script. I does solve the problem.

 

I did that long back, sorry for late reply.

 

 

Thanks

0 Kudos
Reply