UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Newbie alex019
Newbie
1,134 Views
Registered: ‎11-07-2017

Microblaze MCS debug problem in SDK 2017.3

Jump to solution

Hi,

I have been working on a Microblaze MCS project which started in Vivado/SDK 2017.2 where I was able to build and debug the MCS with no problems at all. I have since moved to Vivado/SDK 2017.3 where the debugging seems not to work at and pushing the debug or run system button in SDK brings up this error message:

 

Screenshot from 2017-11-07 21-37-04.png

 

I am able to program the FPGA through SDK confirming that the JTAG drivers are working. I have also tried restarting the project from scratch in 2017.3 to rule out any problems in converting projects from one version of Vivado to another.

I am running Vivado on Linux and using an Arty dev board. Attached are the project .hdf and .mmi files

 

Thanks for your help.

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
1,642 Views
Registered: ‎01-15-2014

Re: Microblaze MCS debug problem in SDK 2017.3

Jump to solution

Here's a patch for 2017.3. You can either extract it to $XILINX_SDK, where $XILINX_SDK points to your SDK installation (ex. C:\Xilinx\SDK\2017.3), or extract it to a known location (C:\temp\myvivado) and set the env variable MYVIVADO to point to this directory ($MYVIVADO should have scripts dir from the patch)

0 Kudos
3 Replies
Xilinx Employee
Xilinx Employee
1,102 Views
Registered: ‎10-21-2010

Re: Microblaze MCS debug problem in SDK 2017.3

Jump to solution

Hi,

Looks like some info is missing from HDF, so there are some internal errors while trying to get the CPU index from HDF. We'll look into this more and provide an update

0 Kudos
Xilinx Employee
Xilinx Employee
1,643 Views
Registered: ‎01-15-2014

Re: Microblaze MCS debug problem in SDK 2017.3

Jump to solution

Here's a patch for 2017.3. You can either extract it to $XILINX_SDK, where $XILINX_SDK points to your SDK installation (ex. C:\Xilinx\SDK\2017.3), or extract it to a known location (C:\temp\myvivado) and set the env variable MYVIVADO to point to this directory ($MYVIVADO should have scripts dir from the patch)

0 Kudos
Newbie alex019
Newbie
991 Views
Registered: ‎11-07-2017

Re: Microblaze MCS debug problem in SDK 2017.3

Jump to solution

Hi,

 

Thank you for the patch, this has solved the problem.

0 Kudos