UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
1,285 Views
Registered: ‎07-28-2008

My Win10 SDK compile is 10x slower than Ubuntu

Jump to solution

Didn't notice as much a difference when I was on Win7.

 

Any insight on how to speed up Win10 compile?

 

Thanks,

Tags (4)
0 Kudos
1 Solution

Accepted Solutions
Scholar austin
Scholar
1,897 Views
Registered: ‎02-27-2008

Re: My Win10 SDK compile is 10x slower than Ubuntu

Jump to solution

Check you do not have a virus,

 

Check what else is running.

 

Sounds like a typical windoze machine issue.....

Austin Lesea
Principal Engineer
Xilinx San Jose
0 Kudos
3 Replies
Scholar austin
Scholar
1,898 Views
Registered: ‎02-27-2008

Re: My Win10 SDK compile is 10x slower than Ubuntu

Jump to solution

Check you do not have a virus,

 

Check what else is running.

 

Sounds like a typical windoze machine issue.....

Austin Lesea
Principal Engineer
Xilinx San Jose
0 Kudos
962 Views
Registered: ‎01-16-2018

Re: My Win10 SDK compile is 10x slower than Ubuntu

Jump to solution

I solved this problem by excluding the Vivado and SDK installation folder from Windows Defender.

 

  • Open Windows Defender Security Center
  • Click on Virus & threat protection
  • Click on Virus & threat protection settings
  • Scroll down to Exclusions, click Add or remove exclusions
  • Add folder:  C:\Path\To\Xilinx\Installation

This cut the time to build a basic BSP down from 114 seconds to 23 seconds...much closer to the times we see on Ubuntu!

0 Kudos
Visitor amucha
Visitor
811 Views
Registered: ‎05-22-2018

Re: My Win10 SDK compile is 10x slower than Ubuntu

Jump to solution

Hello @legendbb,

you tagged @austin's reply as solution, could you maybe give a hint as to what was the actual cause, respectively solution in your case?

Thanks!

 

We're discussing the same problem (on Windows 7 x64) in this thread:

https://forums.xilinx.com/t5/Embedded-Development-Tools/SDK-very-slow-while-building-project/td-p/855090

0 Kudos