UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
4,428 Views
Registered: ‎08-08-2008

Need to manually copy ngc files from pcores->netlist folder

Jump to solution

Hi all,

  I am using coregen generated ngc files as part of a IP core with mix of verilog and ngc files.  The top of the IP is of course VHDL.

  I have followed instructions to include the line "OPTION STYLE = MIX" in MPD file.  Created netlist folder at the same level as data, hdl folder and copied the ngc files into it.  Added "myip_v2_1_0.bbd" file in data folder with contents:

 

FILES
syncfifo.ngc, fifo_generator_v9_2.ngc

 

  Finally I rescan user repository to let EDK update the IP.  However, I get the message "...unable to resolve syncfifo... in myip_submodule.v  ...may be a pin mispelling" error, typically meaning EDK cannot locate the ngc file.

 

  But when I copied the ngc files to implementation folder and generate bitstream again, EDK is able to complete to bitstream generation. 

 

  Does anyone know where I went wrong?  Could it be I must still include the syncfifo.v and fifo_generator_v9_2.v top level file (provided by coregen) in verilog folder and update PAO file to include them?

 

Thanks,

 

Wei Thiam

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Scholar golson
Scholar
5,675 Views
Registered: ‎04-07-2008

Re: Need to manually copy ngc files from pcores->netlist folder

Jump to solution

Just meant to include the Verilog file with the same name as the NGC file in your PAO file.  in your case I guess it is

syncfifo.v.  If it was my design I would put the syncfifo.v file in the same directory as the userlogic.v file and place

the file in the pao file in the list.  The ngc file is placed in a netlist directory.  the import wizard will create a netlist directory

for you and automatically copy the ngc file in it if you go through the import wizard.

 

Yes when you import make sure you choose mixed for hdl otherwise it will remove your verilog file from the pao file.

 

also in the import wizard you should choose netlist checkbox so it will ask for the ngc file at the correct time.

 

I believe you should be importing your design so that it will include the ngc files.  But maybe if you create a netlist directory

and place the ngc files in the directory it might work that way.  I go through the import process and can get a good

result that way.

 

 

4 Replies
Scholar golson
Scholar
4,419 Views
Registered: ‎04-07-2008

Re: Need to manually copy ngc files from pcores->netlist folder

Jump to solution

Did you check the checkbox netlist as well as the the other one.  If you do this then at the end of importing the ipif

design a pop up box will come up and you are supposed to add the ngc files in that box.

 

I believe you need to include the fifo.v file for the fifo.  you don't need to include the generator file you are referring to.

0 Kudos
Adventurer
Adventurer
4,412 Views
Registered: ‎08-08-2008

Re: Need to manually copy ngc files from pcores->netlist folder

Jump to solution

Hi Golson,

  My design is not a pure netlist design.  It is a mainly Verilog design with two netlist modules generated from Coregen.  When you mentioned check the checkbox netlist, maybe you are referring to using some kind of wizard to import.  I actually edited the PAO and MPD files myself.  I will try the import method next time.

  You sure that I only need fifo.v file?  The compiler is actually looking for syncfifo module, and I have checked syncfifo.v, it did not include any fifo.v module.

 

Thanks,

 

Wei Thiam

0 Kudos
Mentor hgleamon1
Mentor
4,404 Views
Registered: ‎11-14-2011

Re: Need to manually copy ngc files from pcores->netlist folder

Jump to solution

If you are using a top level of VHDL and using Verilog files as well you should have the OPTION HDL = MIXED in the MPD.

 

However, for cores specified as a blackbox, the .v (or .vhd) files are not used for synthesis, only simulation, so this shouldn't really matter if you specify them in the PAO or not (recommended practice is to do so, though).

 

This doesn't help you with your missing syncfifo, though. Are you sure the spelling is correct?

 

Regards,

 

Howard

 

----------
"That which we must learn to do, we learn by doing." - Aristotle
Highlighted
Scholar golson
Scholar
5,676 Views
Registered: ‎04-07-2008

Re: Need to manually copy ngc files from pcores->netlist folder

Jump to solution

Just meant to include the Verilog file with the same name as the NGC file in your PAO file.  in your case I guess it is

syncfifo.v.  If it was my design I would put the syncfifo.v file in the same directory as the userlogic.v file and place

the file in the pao file in the list.  The ngc file is placed in a netlist directory.  the import wizard will create a netlist directory

for you and automatically copy the ngc file in it if you go through the import wizard.

 

Yes when you import make sure you choose mixed for hdl otherwise it will remove your verilog file from the pao file.

 

also in the import wizard you should choose netlist checkbox so it will ask for the ngc file at the correct time.

 

I believe you should be importing your design so that it will include the ngc files.  But maybe if you create a netlist directory

and place the ngc files in the directory it might work that way.  I go through the import process and can get a good

result that way.