UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer jcatelli
Observer
860 Views
Registered: ‎02-12-2014

Need to set compiler option -ftemplate-backtrace-limit=0 in SDK 2018.2.2

Jump to solution

I just upgraded a project from SDK2017.2 to SDK 2018.2.2.   In doing so I'm receiving the following error which is just a warning.

 

  [ skipping x instantiation contexts, use -ftemplate-backtrace-limit=0 to disable ]

 

How can I set this compiler option in SDK?   I've looked project properties, C/C++ Build -> Seetings -> Tool Settings but I can't seem to find an option that fits.  

 

Does anyone have an idea on how to set this compiler switch?

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
831 Views
Registered: ‎12-21-2016

Re: Need to set compiler option -ftemplate-backtrace-limit=0 in SDK 2018.2.2

Jump to solution

Hi,

Please try specifying the option in C/C++ Build Settings as shown in the following screenshot

Regards,
Raju
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.

View solution in original post

Untitled.png
0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
832 Views
Registered: ‎12-21-2016

Re: Need to set compiler option -ftemplate-backtrace-limit=0 in SDK 2018.2.2

Jump to solution

Hi,

Please try specifying the option in C/C++ Build Settings as shown in the following screenshot

Regards,
Raju
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.

View solution in original post

Untitled.png
0 Kudos
Observer jcatelli
Observer
821 Views
Registered: ‎02-12-2014

Re: Need to set compiler option -ftemplate-backtrace-limit=0 in SDK 2018.2.2

Jump to solution
Worked like a champ. Thanks for the assistance.
0 Kudos