UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
535 Views

No source available - but code is there

Jump to solution

Hello,

 

I'm having issues with my sdk uBlaze design where I get an error shown below saying "No source available for "main() at helloworld.c: 182 0x958""

1.jpg

 

As you can see in the bottom right the pointer has stopped inside main showing the correct assembly code and the first function I execute "init_platform()".

 

This shows the c code and the beginning of main being pointed to as well.  

2.jpg

 

I also have this issue with _start() a lot.  I have seen many others on the forum have run into issues like this and in searching the forum I can't find any real solutions.  How does one troubleshoot this?  

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
530 Views

Re: No source available - but code is there

Jump to solution

Hi @m3atwad,

 

The default Local Target Connection does not have a checkbox to enable/disable Symbol Server at it has already enabled, that's why you are not seeing the checkbox.

 

However if you create a new Target Connection, you will see the checkbox as shown in the image posted by @evgenis1.

 

Regards

Ibai

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
3 Replies
Highlighted
Advisor evgenis1
Advisor
484 Views

Re: No source available - but code is there

Jump to solution

Hi @m3atwad,

 

One thing that might cause the problem is unchecked "Use Symbol Server" checkbox on Target Connection dialog. See attached screenshot.

 

Thanks,

Evgeni

Tags (1)
target_connection.jpg
0 Kudos
Adventurer
Adventurer
473 Views

Re: No source available - but code is there

Jump to solution

Hello and thank you for the response!  I only see this on my target connections.

 

1.jpg

0 Kudos
Moderator
Moderator
531 Views

Re: No source available - but code is there

Jump to solution

Hi @m3atwad,

 

The default Local Target Connection does not have a checkbox to enable/disable Symbol Server at it has already enabled, that's why you are not seeing the checkbox.

 

However if you create a new Target Connection, you will see the checkbox as shown in the image posted by @evgenis1.

 

Regards

Ibai

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos