cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mutt1
Observer
Observer
1,739 Views
Registered: ‎09-01-2017

Petalinux-create @2017.1 can't find package xsdb

so Petalinux-create -v returns error "can't find package xsdb" but at prompt "which xsdb" returns /opt/xilinx/Vivado/2017.1/bin and xsdb starts.

 

can anyone suggest why petalinux-create fails in this manner?

 

Matt

0 Kudos
4 Replies
stephenm
Moderator
Moderator
1,718 Views
Registered: ‎09-12-2007

Not sure why the bitbake cant find the xsdb, but you could try update the build\conf\plnxtoo.conf with this info:

 

EXTERNAL_TOOLCHAIN_microblaze = "/opt/Xilinx/SDK/2017.1/microblaze/linux_toolchain/lin64_le"

XILINX_SDK_TOOLCHAIN = "/opt/Xilinx/SDK/2017.1"

0 Kudos
mutt1
Observer
Observer
1,693 Views
Registered: ‎09-01-2017


@stephenm wrote:

Not sure why the bitbake cant find the xsdb, but you could try update the build\conf\plnxtoo.conf with this info:

 

EXTERNAL_TOOLCHAIN_microblaze = "/opt/Xilinx/SDK/2017.1/microblaze/linux_toolchain/lin64_le"

XILINX_SDK_TOOLCHAIN = "/opt/Xilinx/SDK/2017.1"


thanks for putting me on the right path, looking closer at the reason why those files don't exist I think there is something missing from my tools .

 

the helpful message on source /opt/petalinux/settings.sh

 

environment: line 314: ((: 10#15~rc1 > 10#3: syntax error in expression (error token is "~rc1 > 10#3")
environment: line 318: ((: 10#15~rc1 < 10#3: syntax error in expression (error token is "~rc1 < 10#3")
environment: line 314: ((: 10#29b: value too great for base (error token is "10#29b")
environment: line 318: ((: 10#29b: value too great for base (error token is "10#29b")

 

unfortunately petalinux-env-check is binary so I can't see what is missing.

0 Kudos
mutt1
Observer
Observer
1,680 Views
Registered: ‎09-01-2017

I have also checked on all the packages listed in UG1144. They are all installed, and the only large difference in version is that of gcc v7 installed vs gcc v4.8 required. However I don't believe gcc plays a part in petalinux-config but might I guess fail the check on tools. That said, I know gcc 5.5 works just fine.

0 Kudos
fpgastudent
Observer
Observer
1,169 Views
Registered: ‎10-10-2017

Hi,
Did you manage to solve this problem?
0 Kudos