cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jcgcecilia
Visitor
Visitor
8,757 Views
Registered: ‎09-29-2009

Platform Studio 11.4 Create bitstream problem.

Jump to solution

Hi everybody!  

Today I updated Xilins Design Suite from 11.3 to 11.4. The updating process went well and without complications.After this I created a new project using BSB. The problem came when I tried to generate the bitstream for the project. The process does not finish, I mean, it keeps going, and going. The last text displayed in the console is the following                                                                                   ********************************************
Running Xilinx Implementation tools..
*********************************************
xflow -wd implementation -p xc3s500efg320-4 -implement xflow.opt -ise ../__xps/ise/system.ise system.ngc
Release 11.4 - Xflow L.68 (nt)
Copyright (c) 1995-2009 Xilinx, Inc. All rights reserved.
xflow.exe -wd implementation -p xc3s500efg320-4 -implement xflow.opt -ise
../__xps/ise/system.ise system.ngc
PMSPEC -- Overriding Xilinx file <C:/Xilinx/11.1/EDK/spartan3/data/spartan3.acd>
with local file <c:/Xilinx/11.1/ISE/spartan3/data/spartan3.acd>

Using Flow File: D:/vhdl_projects/xikernel/implementation/f pga.flw 
Using Option File(s):  
                                                                                                                                                               After that nothing happens. Is anybody there who knows what is happening? Thanks a lot.

0 Kudos
1 Solution

Accepted Solutions
xiaofeip_dup
Xilinx Employee
Xilinx Employee
10,376 Views
Registered: ‎08-07-2007

Hi Guys,

 

If you are seeing  XPS hangs when implementing a design, and if it's because that it has no write permission to xflow.opt file, it's usually because the security settings of your machine conflicts with Cygwin, please do the following to work around it:

add the Environment Variable CYGWIN=nontsec as follows:
http://www.xilinx.com/support/answers/25492.htm
1. Right-click the My Computer icon and select Properties.
2. Select the Advanced tab.
3. Select the Environment Variables button.
4. Under System variables, select the New button.
5. For the variable name, enter CYGWIN.
6. For the variable value, enter "nontsec".
7. Select the OK button three times.
8. If XPS was open, restart XPS so that it will recognize the new environment variable. 

 


-Felix

View solution in original post

0 Kudos
10 Replies
jcgcecilia
Visitor
Visitor
8,752 Views
Registered: ‎09-29-2009

Never mind! Problem solved!!

0 Kudos
svalil
Visitor
Visitor
8,700 Views
Registered: ‎12-22-2009

I have the same problem.

Would you please tell me how you solved it?

 

0 Kudos
vytautas
Explorer
Explorer
8,398 Views
Registered: ‎10-01-2007

Hello.

I have very similar problem. I think this is related to paths problems and Cygwin application.

I fallow this instruction http://www.xilinx.com/support/answers/23716.htm to solve this one.

What I get?: No matter double click of XPS (icon) or executing XPS command from command line I get black window with waiting process. Only version of Xilinx appears and run.exe program is running in Processes without using CPU. IfI kill run.exe, xps continues the running.

I deleted required registries from mounts v2 key like it was described in  answers link. I launched Xilinx bash Shell to create registries, but nothing appears on these keys. Also, variable XILINX_EDK_DISABLE_CYGWIN_CHECK=1 was added.

 Also, export to SDK cannot be complete too:

xps_sdk.bat -workspace C:\Xilinx_projects\VR_FFT256_LOG_epsilion2\SDK\SDK_Workspace\ -hwspec C:\Xilinx_projects\VR_FFT256_LOG_epsilion2\SDK\SDK_Export\hw\system.xml & started...

Here again findstr.exe file should be killed.

So, I have installed only xilinx Cygwin (no others) and cannot solve this issue...

 Thanks.

Regards,

Vytautas

Message Edited by vytautas on 03-07-2010 03:01 PM
Best Regards,
Vytautas
0 Kudos
vytautas
Explorer
Explorer
8,256 Views
Registered: ‎10-01-2007

Hi.

If you met  such problem, you can use CCleaner tool to clean-up  registies. It helped me to avoid this issue.

Best Regards,
Vytautas
0 Kudos
arwa
Contributor
Contributor
8,217 Views
Registered: ‎02-18-2008
I have the same problem when I try to generate a bitstream. How did you fix it?
0 Kudos
vytautas
Explorer
Explorer
8,210 Views
Registered: ‎10-01-2007

Hi,

I did many experiments with registers, because as I understood, this issue is related to not found required way to cygwin files. So, clean up your registers with CCleaner tools. Then you can try to do following this instruction:

http://www.fpga.lt/index.php?option=com_content&view=article&id=8:cygwin&catid=17:problemos-sprendimai&Itemid=44

and here:

http://www.xilinx.com/support/answers/25395.htm

This is in Lithuanian language, but you can translate if you need :)

 Regards,

Vytautas

Best Regards,
Vytautas
0 Kudos
arwa
Contributor
Contributor
8,204 Views
Registered: ‎02-18-2008
This didn't solve my problem.
0 Kudos
arwa
Contributor
Contributor
8,179 Views
Registered: ‎02-18-2008

Problem solved!

 

Seemed to be an access right problem with the .ucf and the xflow.opt files, even though I have admin privileges. ISE has always worked fine, the problem seems to be only with XPS. The bitstream generation works fine if the project isn't saved in the C drive.

0 Kudos
xiaofeip_dup
Xilinx Employee
Xilinx Employee
10,377 Views
Registered: ‎08-07-2007

Hi Guys,

 

If you are seeing  XPS hangs when implementing a design, and if it's because that it has no write permission to xflow.opt file, it's usually because the security settings of your machine conflicts with Cygwin, please do the following to work around it:

add the Environment Variable CYGWIN=nontsec as follows:
http://www.xilinx.com/support/answers/25492.htm
1. Right-click the My Computer icon and select Properties.
2. Select the Advanced tab.
3. Select the Environment Variables button.
4. Under System variables, select the New button.
5. For the variable name, enter CYGWIN.
6. For the variable value, enter "nontsec".
7. Select the OK button three times.
8. If XPS was open, restart XPS so that it will recognize the new environment variable. 

 


-Felix

View solution in original post

0 Kudos
Anonymous
Not applicable
1,942 Views

Thanks Felix, this solved the problem :)

0 Kudos