cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
8,580 Views
Registered: ‎01-30-2009

Problem integrating EDK project in ISE 10.1

Jump to solution

Hi,

I just installed the latest service packs for EDK and ISE and trying to combine my EDK top level and my VHDL codes in ISE. But no matter what I do, I get the following error message:

 


Xilinx Platform Studio
Xilinx EDK 10.1.03 Build EDK_K_SP3.6
Copyright (c) 1995-2008 Xilinx, Inc.  All rights reserved.

ERROR:MDT - Error while performing Cygwin checks....
ERROR: The Device Settings in the ISE project do not match those in
 the XPS project. You will need to change them so that they
 match in order to use the XPS design with ISE.

 I have looked at:

http://www.xilinx.com/support/answers/30456.htm

http://www.xilinx.com/support/answers/30846.htm

 

And even re-installed my ISE but nothing seems to work.

 

Does anyone know how I can solve this?

 

Individually both tools work without any problems, but it seems like my ISE does not like the EXACT same device used on EDK.

 

Really appreciate your help,

 

Best regards,

/Farhad

PS. I am on Windows XP

 

Tags (5)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Visitor
Visitor
9,905 Views
Registered: ‎01-30-2009

Solved the problem myself by installing the latest Cygwin to my PC and copied it over the old Cygwin under EDK.

 

After that, I re-generated all the libraries and re-created all the applications, that solve the problem.

 

This is really unprofressional of Xilinx not to include the correct Cygwin with the latest EDK installation.

 

BR,

/Farhad

 

 

View solution in original post

0 Kudos
4 Replies
Highlighted
Visitor
Visitor
8,546 Views
Registered: ‎01-30-2009

Ok,

I re-installed  both the ISE and EDK and updated them to SP3. Now the connection between the 2 tools work fine,but I can no longer generate simulation files to simulate my design.

 

I get the following error message:

 

Copying files for driver cpu_v1_11_b from
C:\Xilinx\10.1\EDK\sw\XilinxProcessorIPLib\drivers\cpu_v1_11_b\src\ to

<name removed>\FPGA\edk\microblaze_0\libsrc\cpu_v1_11_b\ ...
/usr/bin/bash: igncr: unknown option name
/usr/bin/bash: igncr: unknown option name
ERROR:MDT - Error while running "Copy Files" for processor microblaze_0...
/usr/bin/bash: igncr: unknown option name
make: *** [microblaze_0/lib/libxil.a] Error 2
Done!

 

Does this mean that the cygwin included in EDK is not fully compatible with the EDK?

 

TIA,

/Farhad

0 Kudos
Highlighted
Visitor
Visitor
9,906 Views
Registered: ‎01-30-2009

Solved the problem myself by installing the latest Cygwin to my PC and copied it over the old Cygwin under EDK.

 

After that, I re-generated all the libraries and re-created all the applications, that solve the problem.

 

This is really unprofressional of Xilinx not to include the correct Cygwin with the latest EDK installation.

 

BR,

/Farhad

 

 

View solution in original post

0 Kudos
Highlighted
Historian
Historian
8,520 Views
Registered: ‎02-25-2008

fabdolian wrote:

 

This is really unprofressional of Xilinx not to include the correct Cygwin with the latest EDK installation.

 


 

The latest Cygwin is a moving target.  By the time the Xilinx tools ship, Cygwin has moved on.

 

The real problem is that newer versions of Cygwin might not be completely compatible with earlier versions.

 

-a

----------------------------Yes, I do this for a living.
0 Kudos
Highlighted
Visitor
Visitor
8,487 Views
Registered: ‎01-30-2009
I don't agree with you here. It is not that Cygwin is installed seperately, but it is the one sent by Xilinx even after the installation of the SP3 that does not work, I would have been more than happy to remove Cygwin from my system (as I did) and only install Xilinx ISE and EDK, but the problem was that the Cygwin version delivered wuth EDK didn't work for me.
0 Kudos