UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Scholar dpaul24
Scholar
9,414 Views
Registered: ‎08-07-2014

Problem with Linken script generation (Viv + SDK 2015.4) for MicroBlaze 9.5

Jump to solution

Hi,

 

I have successfully implemented and exported to SDK a Microblaze design having 256MB BRAM as instruction memory (via ILMB) and UARTLite other than clocks and resets.

 

However when I am trying to create hello world C code, I am getting a "Error generating Linker script" message. Below I have copied the messages from the SDK Log window.

 

17:08:19 INFO	: Launching XSDB server: xsdb.bat C:/Xilinx/SDK/2015.4/scripts/xsdb/xsdb/xsdb-server.tcl
17:08:20 INFO	: XSDB server has started successfully.
17:08:20 INFO	: Processing command line option -hwspec D:/work/Xilinx/uB_sys_design/uB_bd/uB_sys.sdk/uB_bd_wrapper.hdf.
17:11:45 ERROR	: (XSDB Server)ERROR: [Hsi 55-1573] The hardware system does not have a memory that can locate program data Section 
ERROR: [Hsi 55-1422] Cannot initialize LinkGen Engine.
ERROR: [Hsi 55-1435] Error generating linker script

17:11:45 ERROR	: (XSDB Server)ERROR: [Hsi 55-1438] Error running generate_app.

17:11:45 ERROR	: Failed to call GENERATE_APP 
Reason: ERROR: [Common 17-39] 'hsi::generate_app' failed due to earlier errors.

17:11:45 ERROR	: 
java.lang.RuntimeException: Failed to call GENERATE_APP 
Reason: ERROR: [Common 17-39] 'hsi::generate_app' failed due to earlier errors.

The GUI Error window is also attached.

 

Could it be that the BMM file for the uBlaze was not properly imported?

 

Please direct me to solutions and/or suggestions in order to resolve the error.

--------------------------------------------------------------------------------------------------------
FPGA enthusiast!
All PMs will be ignored
--------------------------------------------------------------------------------------------------------
linker_script.jpg
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Scholar stephenm
Scholar
17,891 Views
Registered: ‎05-06-2012

Re: Problem with Linken script generation (Viv + SDK 2015.4) for MicroBlaze 9.5

Jump to solution

Can you post a screenshot of your BD (Block design) of your memory structure. it sounds like you havent connected your DLMB memory on the Microblaze?

0 Kudos
2 Replies
Highlighted
Scholar stephenm
Scholar
17,892 Views
Registered: ‎05-06-2012

Re: Problem with Linken script generation (Viv + SDK 2015.4) for MicroBlaze 9.5

Jump to solution

Can you post a screenshot of your BD (Block design) of your memory structure. it sounds like you havent connected your DLMB memory on the Microblaze?

0 Kudos
Scholar dpaul24
Scholar
9,267 Views
Registered: ‎08-07-2014

Re: Problem with Linken script generation (Viv + SDK 2015.4) for MicroBlaze 9.5

Jump to solution

Hi Stephenm,

 

Yes, I have left the DLMB unconnected.

 

Ah....now I see, the following message points to it! I think I can fix it.

7:11:45 ERROR	: (XSDB Server)ERROR: [Hsi 55-1573] The hardware system does not have a memory that can locate program data Section

I should have read the error message more carefully! But it was Friday evening when I posted this message so...............

 

;-)

--------------------------------------------------------------------------------------------------------
FPGA enthusiast!
All PMs will be ignored
--------------------------------------------------------------------------------------------------------
0 Kudos