cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Observer
Observer
1,840 Views
Registered: ‎04-03-2011

Problems with Ethernet transmission using lwip and the XUPV2P board

Hi!

 

Recently I have managed to start up the echo server example project provided by Xilinx, which uses lwIP in RAW mode. I am using EDK10.1 and the XUPV2P board. My design is based on the PowerPC 405. The only difference between my project and the sample echo server is in the use of the caches. To be more precise, I had to remove those lines of code which were initializing the instruction and the data cache, because they won't let the board to boot up. However, the echo server worked nicely without any kind of trouble until I tried to send an image from my PC to the board (I tried to send the image line by line, attaching some header to every line, so the final packet size was 1082 bytes). After the first two packets the XUPV2P board wouldn't return any ACK's to my PC, nor could the PC send any more packets. Can this problem be caused by the lack of the caches?

If so, how should I enable them? I found the functions that are corresponding to the PowerPC405 (XCache_EnableICache and XCache_EnableDCache) but I cannot figure out what should the parameter be for them. I have the base address for the Ethernet_MAC between: 0x81000000 and 0x8100ffff, and for the DDR memory 0x00000000 - 0x1fffffff.

I've seen some similar posts on the forum, but the solutions presented there weren't applicable to my project - or I haven't understood them.

Any help is appreciated.

 

Ferenc

0 Kudos
0 Replies