cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
fiedel
Explorer
Explorer
1,643 Views
Registered: ‎12-21-2012

Python version for Petalinux.

Jump to solution

Where can I find the Python version for each Peatlinux release? I didn't see it in ug1144. I strugled a lot when I started to use Petalinux, and I don't suffer from python version again as I plan to upgrade to 2019.2.

Or, 2019.2 still uses Python 2.7?

0 Kudos
1 Solution

Accepted Solutions
vineethc
Xilinx Employee
Xilinx Employee
1,638 Views
Registered: ‎06-29-2017

The python package for petalinux tool comes from within.

Petalinux leveragtes build tools concept of yocto.

It is independent of host python version.

View solution in original post

5 Replies
vineethc
Xilinx Employee
Xilinx Employee
1,639 Views
Registered: ‎06-29-2017

The python package for petalinux tool comes from within.

Petalinux leveragtes build tools concept of yocto.

It is independent of host python version.

View solution in original post

fiedel
Explorer
Explorer
1,634 Views
Registered: ‎12-21-2012

That makes me feel much better. Maybe I have corrupted memory...

Thanks.

0 Kudos
vineethc
Xilinx Employee
Xilinx Employee
1,629 Views
Registered: ‎06-29-2017

what was the error ?

0 Kudos
erjo1776
Newbie
Newbie
1,242 Views
Registered: ‎06-19-2020

~/tools/u96a$ bash petalinux-v2018.3-final-installer.run ~/tools/u96a
INFO: Checking installation environment requirements...
WARNING: This is not a supported OS
INFO: Checking free disk space
INFO: Checking installed tools
ERROR: You are missing the following system tools required by PetaLinux:

- python
Please check PetaLinux installation guide - required tools and libraries package section for detailed information

INFO: Checking installed development libraries
Please install them with your operating system package manager, and try again
WARNING: Please install required packages.

Please refer to the PetaLinux Tools Installation Guide.

Check the troubleshooting guide at the end of that manual, and if you are
unable to resolve the issue please contact customer support with file:

----------btw, I too am trying WSL Ubuntu under Windows 10 pro-------------

0 Kudos
akarshana
Adventurer
Adventurer
630 Views
Registered: ‎03-06-2015

I am getting same error please let me know the solution for this

0 Kudos