UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor radlyeel
Visitor
596 Views
Registered: ‎10-05-2018

RM defined wrong in SDK makefile, 2017.3

Jump to solution

I have an error in the generated makefile in a Xilinx SDK C++ project.  Near the top of the file is the line

  RM :=    -rf

Clearly it should be

  RM := rm -rf

The effect is that when I run "clean" I get an error from the make command saying it (of course) could not find the rf command.

 

So two questions arise:

1.  How does this happen?

2.  Can I, despite the warning comment in the makefile, edit the makefile and expect the change to stick?

0 Kudos
1 Solution

Accepted Solutions
Visitor radlyeel
Visitor
530 Views
Registered: ‎10-05-2018

Re: RM defined wrong in SDK makefile, 2017.3

Jump to solution

And the workaround is:

 

Instead of right-clicking in the Project Explorer, it turns out you really do have to start with File->New->Application Project.  From there, everything seems to go well.  I think I was supposed to know to start there; now I know why.

 

But I still think Xilinx should fix that.

0 Kudos
4 Replies
Moderator
Moderator
544 Views
Registered: ‎10-06-2016

Re: RM defined wrong in SDK makefile, 2017.3

Jump to solution
Hi @radlyeel,

I just tested an example application for A9 and A53 cores in SDK 2017.3 release and I was not able to find the error.

Could you clarify to which makefile are you referring, and which kind of target are you using?

Regards
Ibai

Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos
Visitor radlyeel
Visitor
534 Views
Registered: ‎10-05-2018

Re: RM defined wrong in SDK makefile, 2017.3

Jump to solution

Here are the steps to reproduce this problem:

 

Create a new SDK project in the location of your choice.
    In the Project Explorer pane, right-click in some empty space and
    select New-->C++ Project.  In the "Project name" field type "demos"
    and select "Hello World ARM C++ Project".  Click "Next" and complete the
    first three fields of the Basic Settings as needed.  Click "Next".
    Click "Advanced settings..." Expand the C/C++ Build item if necessary. 

    Select Tool Chain Editor.  In "Current toolchain", click the drop-
    down list and select "Xilinx ARM v7 GNU/Linux Toolchain".  Click OK, and
    on the "Select Configuration" panel click "Next>".  Click "Finish".

 

At this point, click the "build" icon (the hammer) and then open the makefile in the Debug folder.  :ine 7 will say

   RM :=    -rf

whereas it should say

   RM := rm -rf

 

The issue is complicated by the fact that I myself have a working (i.e., with correct RM definition) makefile, and I'm trying to do a "How to" for my colleagues, and they all have the same issue, as do I when I follow these steps.  Somehow I managed to get a working makefile and now I don't know how I did that.  There may be some other sequence to arrive at the same project settings, and that would work for me.  I'll continue to try other paths, but in my world, this would be a bug.

0 Kudos
Visitor radlyeel
Visitor
531 Views
Registered: ‎10-05-2018

Re: RM defined wrong in SDK makefile, 2017.3

Jump to solution

And the workaround is:

 

Instead of right-clicking in the Project Explorer, it turns out you really do have to start with File->New->Application Project.  From there, everything seems to go well.  I think I was supposed to know to start there; now I know why.

 

But I still think Xilinx should fix that.

0 Kudos
96 Views
Registered: ‎06-04-2019

Re: RM defined wrong in SDK makefile, 2017.3

Jump to solution

Problem:

I had faced same issue on SDK 2018.3, while, attempting to create static library projects.

So what I had done to create these projects: File -> New -> Project -> C/C++ -> C++ project -> Static library -> Empty project.

I had chosen Cross Arm GCC at project creation (choosing anything else does not work - i.e. there is an error in Next step:

 

sdkerror1.jpg

I later changed the Tool chain to Xilinx ARM v7 GNU Toolchain (as my app is using this tool chain and this is the default tool chain - I am assuming, according to Zynq 7020 (as captured in BSP-> HW platform Specs -> hdf file):

sdkerror2.jpg

The project build all right but on clean I got error (see screen shot below), Also note the make file generated by SDK RM:= -rf instead of RM:= rm -rf.

 

sdkerror3.jpg

 

Workaround / Solution:

I changed tool chain back to current toolchain: Cross Arm GCC and current builder: GNU make

sdkerror4.jpg

sdkerror4.jpg

Then I set the correct properties of the tool chain and set adjacent build flags in project properties: see two screen shots below:

As Zynq 7020 cpu 0 and 1 are arm cortex_a9

sdkerror5.jpg

Clean works normally after doing this and RM command is also set correctly in auto generated make file:

sdkerror6.jpg

0 Kudos