UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor sssingh
Visitor
4,985 Views
Registered: ‎04-27-2008

Removing Clock Generator and feeding clock from outside EDK

I have a project in which edk is a submodule on a ml505.  I have the following IPs working when there is a clock generator

in EDK that generates 125Mhz from a 100Mhz source: I2C, LEDs, GPIO, UART, FSLs, BRAMs.

 

However, what I really want to do is remove the clock generator from EDK and use PLL instantiated outside of EDK, which will

generate multiple clocks and one of them being 125Mhz to feed uB.  So I did this and now nothing works...even the LEDs.

 

I noticed in the port connection the CLK port of uBlaze is set to DEFAULT connection.

Do I need to explicitly set this to the uB_clk (125Mhz external input port to uBlaze).

 

In general what is "Default Connection" ?

0 Kudos
2 Replies
Explorer
Explorer
4,964 Views
Registered: ‎08-14-2007

Re: Removing Clock Generator and feeding clock from outside EDK

I suspect the default connection is the net defined in the mpd file.

 

Do you have the clock named sys_clk_s and defined it as a clock class in the assembly view port page? 

0 Kudos
Visitor sssingh
Visitor
4,962 Views
Registered: ‎04-27-2008

Re: Removing Clock Generator and feeding clock from outside EDK

I don't follow your answer referencing "clock class".

 

I don't have sys_clk_s but I have an external port named ub_clk (output of PLL) going into the edk subsystem.

Here is a code snippet form mhs file:

  

#These are external ports to edk subsystem

PORT ub_clk = ub_clk, DIR = I, SIGIS = CLK, CLK_FREQ = 125000000

PORT ub_rst = ub_rst, DIR = I, RST_POLARITY = 0, SIGIS = RST
PORT ub_clk_dcm_locked = ub_clk_dcm_locked, DIR = I

...

...

...

BEGIN microblaze
PARAMETER INSTANCE = microblaze_0
PARAMETER HW_VER = 7.10.b
PARAMETER C_USE_EXTENDED_FSL_INSTR = 1
PARAMETER C_FSL_LINKS = 2
PARAMETER C_FAMILY = virtex5
PARAMETER C_INSTANCE = microblaze_0
BUS_INTERFACE DPLB = mb_plb
BUS_INTERFACE IPLB = mb_plb
BUS_INTERFACE DLMB = dlmb
BUS_INTERFACE ILMB = ilmb
BUS_INTERFACE MFSL0 = wr_fsl
BUS_INTERFACE SFSL0 = rd_fsl
PORT MB_RESET = mb_reset
PORT CLK = ub_clk
END

 

I added the PORT CLK = ub_clk just now but I can't try it to see if it works.  When I first posted the message,

I didn't have this line and nothing worked.

 

The default connection in mpd file is:

## Ports
PORT CLK = "", DIR = I, SIGIS = CLK, BUS = DPLB:IPLB:DOPB:IOPB:DLMB:ILMB

 

 

0 Kudos