UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor wangdynasty
Visitor
1,650 Views
Registered: ‎11-22-2012

SD Boot Problems with FSBL in Vivado2016.4

Hi everyone, I am transfering projects from ISE14.7 to Vivado2016.4. With ISE FSBL project, my board can boot successfully and linux run normally, but when using Vivado FSBL project, my board can not boot. Then I debug the FSBL codes, and found that it stopped at a function called f_open(), which should return XST_SUCCESS but my function returns FR_NOT_READY, here is the snapshot.

 

error.jpg
0 Kudos
2 Replies
Visitor wangdynasty
Visitor
1,645 Views
Registered: ‎11-22-2012

Re: SD Boot Problems with FSBL in Vivado2016.4

Here is my board and the TF Card.

 

The ISE project and Vivado project are all the same PS setting and blank PL logic, why the differenct result? Which change cause the problem?

 

BTW, I have tried Vivado 2017.1, also cause the same problem.

WeChat Image_20170619105842.jpg
WeChat Image_20170619105849.jpg
0 Kudos
Highlighted
Visitor han_2012
Visitor
448 Views
Registered: ‎09-17-2017

Re: SD Boot Problems with FSBL in Vivado2016.4

Hi, I also encountered this problem. So, how did you solve this trouble?

Thank you!

Regards

0 Kudos