UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
4,730 Views
Registered: ‎05-28-2014

SDK 14.7 failure in flash programming

Hi all,

 

I am unable to use SDK 14.7 to program binary file into flash of microBlaze. I keep geting the error : "CFI query of block/sector map returned inconsistent result!". 

I see in other thread that other also got this failure with 14.7, while 14.4 works. should I try 14.4 ? Can I install it in the same computer ? Is it suffecient to donwload just the SDK or just the "lab tools" instead of the full package ? 

Thanks,

Ran

0 Kudos
6 Replies
Xilinx Employee
Xilinx Employee
4,716 Views
Registered: ‎04-16-2012

Re: SDK 14.7 failure in flash programming

Hi,

You can install 14.4 in the same machine.
IF you want to install just lab tools, select ISE labtools in one of the installations screens (i.e., select Products to Install)

Thanks,
Vinay
--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Scholar sampatd
Scholar
4,619 Views
Registered: ‎09-05-2011

Re: SDK 14.7 failure in flash programming

We found some issues with the "-Os" optimization flag in the GCC compiler that was used to build the Flashwriter drivers for 14.7 version of the tool. 


flashwriter.png
The workaround for the issue is replacing -Os with -O3 in the GCC command in flashwriter.tcl file @ C:\Xilinx\14.7\ISE_DS\EDK\data\xmd

0 Kudos
Contributor
Contributor
4,379 Views
Registered: ‎09-24-2009

Re: SDK 14.7 failure in flash programming

It works for Virtex-6 LX240 board.

 

Thanks a lot.


@sampatd wrote:

We found some issues with the "-Os" optimization flag in the GCC compiler that was used to build the Flashwriter drivers for 14.7 version of the tool. 


flashwriter.png
@the workaround for the issue is replacing -Os with -O3 in the GCC command in flashwriter.tcl file @ C:\Xilinx\14.7\ISE_DS\EDK\data\xmd


 

 

0 Kudos
Visitor andrescc
Visitor
3,186 Views
Registered: ‎07-29-2010

Re: SDK 14.7 failure in flash programming

It also works for Virtex-5 LX110T.

 

Just be sure also to replace the lines:

 

set EXTRA_COMPILER_FLAGS  -O3

set gcc_cmd "powerpc-eabi-gcc -O3 $mcpu ...

 

Thanks!

0 Kudos
Scholar sampatd
Scholar
3,130 Views
Registered: ‎09-05-2011

Re: SDK 14.7 failure in flash programming

Please mark the above post as "Accept as solution" if it has resolved your issue so that we can close this thread.
0 Kudos
Adventurer
Adventurer
3,051 Views
Registered: ‎05-17-2015

Re: SDK 14.7 failure in flash programming

Thank you,

 

I haven't tried that yet (been working with 14.4 all that time), but I will mark it as a solution and try it in the first opportunity.

 

Thank you!

Ran

0 Kudos