UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
6,636 Views
Registered: ‎10-05-2010

SDK 2014.2 Program FPGA Bitstream Field Greyed Out

I am trying to program my Zynq FPGA through the SDK, but the 'Program FPGA' dialog box displays the error 'No bit file found for the design', and the bitstream Search... and Browse... buttons are greyed out. I exported the hardware and bitsteam to my workspace.

 

I can program the FPGA correctly from Vivado, but I must program from SDK in order to use ChipScope.

 

How do I get SDK to program the FPGA?

 

---

Joe Samson

0 Kudos
6 Replies
Explorer
Explorer
6,609 Views
Registered: ‎10-05-2010

Re: SDK 2014.2 Program FPGA Bitstream Field Greyed Out

I really need to move forward on this design.

 

Mods - any ideas for what's causing this?

 

 

---

Joe Samson

0 Kudos
Xilinx Employee
Xilinx Employee
6,571 Views
Registered: ‎08-02-2007

Re: SDK 2014.2 Program FPGA Bitstream Field Greyed Out

Hi Joe,

 

which board are you trying to download the bitstream?

 

Would that be possible to share the design?

 

--Hem

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Explorer
Explorer
6,563 Views
Registered: ‎10-05-2010

Re: SDK 2014.2 Program FPGA Bitstream Field Greyed Out

I can post it to you privately if you send me a link and tell me what files you need.

 

---

Joe

0 Kudos
Explorer
Explorer
6,538 Views
Registered: ‎10-05-2010

Re: SDK 2014.2 Program FPGA Bitstream Field Greyed Out


@htsvn wrote:

Hi Joe,

 

which board are you trying to download the bitstream?

 

Would that be possible to share the design?

 

--Hem


 

Still waiting for you to tell me what files I need to send you in order to share the design and where I can post them.

 

---

Joe Samson

0 Kudos
Scholar stephenm
Scholar
6,526 Views
Registered: ‎05-06-2012

Re: SDK 2014.2 Program FPGA Bitstream Field Greyed Out

Did you tick the box in the export hardware to add the bitstream?
Can you verify this? You can also right click on the hdf file and open it like you would a zip file, and make sure that the bitstream and BMM file ( if there) is added.

You can also use XMD in SDK to config the fpga:
fpga -f <bitstream name>.bit
0 Kudos
Explorer
Explorer
6,517 Views
Registered: ‎10-05-2010

Re: SDK 2014.2 Program FPGA Bitstream Field Greyed Out


@stephenm wrote:
Did you tick the box in the export hardware to add the bitstream?


Like many other people on the forum report, that checkbox is greyed out. I tried all the workarounds that I could find, but none of them enabled the checkbox. I figured that it was just another of the many things that don't quite work right.

 

One day, every time I exported the hardware and started SDK, a new hardware platform directory would be created. I got tired of  seeing all of them, so I deleted one. When I tried downloading the bitstream from the SDK, the Hardware Platform pulldown gave me the choice of 'None', and that unlocked the browse button for the bitstream. I got to download once, but that trick never worked again.

 

I just opened the hdf file with 7-Zip and there is no bitstream file. That would explain why choosing "None" unlocked the bitstream search - there was no .hdf archive specified. I don't understand why someone thought it was a good idea to ever disable browsing for a bitstream in the dialog box meant for downloading a bitstream. 

 

 

I'll put some more work into trying to figure out how to enable the bitstream checkbox. Thanks for the tip.

 

---

Joe

0 Kudos