UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
7,373 Views
Registered: ‎01-02-2015

SDK 2014.4 adding backslashes to device tree repository path

Using Vivado 2014.4 and SDK 2014.4 on Windows 7 machine.

 

I want to build a device tree from SDK. I have device-tree-xlnx saved in my SDK workspace. The directory structure is <workspace>/repo/bsp/device-tree-xlnx-xilinx-v2014.4/.

 

1) After exporting hardware and bitfile from Vivado to SDK, I choose Xilinx Tools->Repositories->New Local Repository (I've also tried relative local and new global with the repo in various locations).

 

2) Choose the repo directory in my workspace. Apply changes, click OK.

 

3) File->New->Board Support Package. Choose device_tree for Board Support Package OS. Finish.

 

4) Choose OK on Board Support Package Settings.

 

After the log shows multiple errors, I get a popup that says "Failed to generate sources for BSP project device_tree_bsp_0 Reason: Internal error occured while generating bsp sources. Please check the SDK Log view for further details."

 

In the attached log file, you'll see that the search path for the the repo files has both backslashes and forward slashes. Is this the reason that the command is failing? If so, is there another way to set the repo path?

0 Kudos