UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Voyager
Voyager
6,824 Views
Registered: ‎10-07-2011

SDK 2015.2 batch mode timeout

Hi folks,

 

I'm using Vivado and SDK 2015.2 on Win7-64 and trying to use the SDK in batch mode to rebuild the workspace and projects following a fresh checkout from the version control system. Basically, I'm trying to run either of the commands below which shall do the same:

 

W:/EFA0130>xsdk -batch -source BuildSDKProject.tcl
  or
W:/EFA0130>xsct -s BuildSDKProject.tcl

 

The tcl script is as below.


sdk set_workspace .
puts [sdk get_workspace]
sdk import_projects .

 

The xsdk and/or xsct tools invoked are indeed those from 2015.2, as shown below.


W:/EFA0130>which xsdk
E:/Xilinx/SDK/2015.2/bin/xsdk

W:/EFA0130>which xsct
E:/Xilinx/SDK/2015.2/bin/xsct

 

Execution of either commands returns the following.


Got $XILINX_SDK: E:/Xilinx/SDK/2015.2
W:/EFA0130                <<<<<<<<<<<<<<< Resulting from the <puts [sdk get_workspace]> tcl script command
Xilinx Software Development Kit
Xilinx EDK 14.7 Build EDK_P.20131013       <<<<<<<<<<<<<<<<<<<<<<<<<<<<< Does that make sense in 2015.2???
Copyright (c) 1995-2012 Xilinx, Inc.  All rights reserved.
Error in startup script:
timeout while establishing a connection with SDK
    while executing
"error "timeout while establishing a connection with SDK""
    (procedure "getsdkchan" line 56)
    invoked from within
"getsdkchan"
    (procedure "::xsdb::sdk::import_projects" line 18)    <<<<<<<<<< sdk::import_projects is failing!
    invoked from within
"sdk import_projects ."
    (file "BuildSDKProject.tcl" line 4)

 

I found AR #65034 and increased the timeout to 5 minutes, but the issue remained.

 

I do have ISE 14.7 and other Vivado/SDK version installed on my computer. My feeling is that some setting is wrong and that Vivado 2015.2 shall not rely on EDK 14.7 as reported above.

 

Any idea as how to resolve the issue?

 

Cheers,

 

Claude

 

0 Kudos
2 Replies
Visitor ng82
Visitor
5,041 Views
Registered: ‎05-09-2016

Re: SDK 2015.2 batch mode timeout

Hi Claude, 

I am running into the same issue but using Ubuntu 14.04.4. Were you able to find any solution to the problem?

 

Thanks.

0 Kudos
Voyager
Voyager
5,027 Views
Registered: ‎10-07-2011

Re: SDK 2015.2 batch mode timeout

I'm using 2015.4 now but sorry, no solution yet.

 

I should say I have some working scripts (ie executing without error) but I didn't succeed in rebuilding the SDK projects. Below is what I'm using now.

 

#!/usr/bin/tclsh
sdk set_workspace .
puts [sdk get_workspace]
sdk create_hw_project -name HWPlatform -hwspec Externals/EGP0031/TopLevel.hdf
#sdk import_projects .
sdk create_hw_project -name HWPlatform -hwspec Externals/EGP0031/TopLevel.hdf
sdk create_bsp_project -name StandaloneBSP -hwproject HWPlatform -proc microblaze_0 -os standalone
sdk create_app_project -name MainApplication -hwproject HWPlatform -proc microblaze_0 -os standalone -lang C -app {Empty Application} -bsp StandaloneBSP

 

You can either use "import" or "create". I didn't investigate that too much. Sorry.

 

Claude

 

 

0 Kudos