UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
1,169 Views
Registered: ‎12-25-2014

SDK 2016.2 getting stuck in "Initializing s/w repositories" stage

Jump to solution

I am running Windows 10 (latest update). I have Vivado & SDK 2016.2 installed. Upon building a project in Vivado, exporting the hardware & launching SDK through Vivado, the SDK windows opens but is getting stuck in "Initializing s/w repositories" phase. It took 1hr to do this & the SDK log showed following 

 

15:06:14 INFO    : Launching XSDB server: xsdb.bat -interactive E:\hdl_dev_adc_dac_MEO_Booster_v00\projects\fmcomms5\zc706\fmcomms5_zc706.sdk\temp_xsdb_launch_script.tcl
15:06:16 INFO    : XSDB server has started successfully.
15:06:16 INFO    : Restoring global repository preferences:
         C:\Xilinx
16:06:38 ERROR    : (XSDB Server)ERROR: [Hsi 55-1433] Error boost::filesystem::status: Access is denied: "C:/Xilinx\SDK\2016.2\gnu\microblaze\linux_toolchain\nt64_be\microblaze-xilinx-linux-gnu\lib32"

16:06:38 ERROR    : (XSDB Server)ERROR: [Hsi 55-1433] Error boost::filesystem::status: Access is denied: "C:/Xilinx\SDK\2016.2\gnu\microblaze\linux_toolchain\nt64_le\microblazeel-xilinx-linux-gnu\lib32"

16:06:38 ERROR    : (XSDB Server)ERROR: [Hsi 55-1433] Error boost::filesystem::status: Access is denied: "C:/Xilinx\SDK\2016.2\gnu\microblaze\linux_toolchain\nt_le\microblazeel-xilinx-linux-gnu\lib32"

16:07:21 ERROR    : Internal error. Unable to add C:\Xilinx as a repository.
16:07:21 INFO    : Processing command line option -hwspec E:/hdl_dev_adc_dac_MEO_Booster_v00/projects/fmcomms5/zc706/fmcomms5_zc706.sdk/system_top.hdf. 

 

So, two questions, why is initialization taking so long & what is the above error I received?

0 Kudos
1 Solution

Accepted Solutions
Adventurer
Adventurer
1,007 Views
Registered: ‎12-25-2014

Re: SDK 2016.2 getting stuck in "Initializing s/w repositories" stage

Jump to solution
I tried the proxy settings you suggested but it didn't affect anything. Initializing s/w repositories was still taking forever. So, once I it was over & s/w repositories were finally initialized, I removed C:\Xilinx from Global repositories. Now, SDK doesn't get stuck every time I launch it. That temporary solution is OK for me as of now
6 Replies
Moderator
Moderator
1,125 Views
Registered: ‎11-09-2015

Re: SDK 2016.2 getting stuck in "Initializing s/w repositories" stage

Jump to solution

HI @kharobangdo,

 

It seems that SDK does not have the right to access the installation folders. Could you check if you can read or write files into these folders?


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Adventurer
Adventurer
1,083 Views
Registered: ‎12-25-2014

Re: SDK 2016.2 getting stuck in "Initializing s/w repositories" stage

Jump to solution

Yes, I can read & write files in C:\Xilinx\SDK directory. So what seems to be the problem

0 Kudos
Moderator
Moderator
1,076 Views
Registered: ‎11-09-2015

Re: SDK 2016.2 getting stuck in "Initializing s/w repositories" stage

Jump to solution

Hi @kharobangdo,

 

Can you try to run SDK as administrator?


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Adventurer
Adventurer
1,072 Views
Registered: ‎12-25-2014

Re: SDK 2016.2 getting stuck in "Initializing s/w repositories" stage

Jump to solution

The account on my PC is itself an Administrator account. So launching SDK through Vivado would be equivalent to launching it as an administrator no?

0 Kudos
Moderator
Moderator
1,070 Views
Registered: ‎11-09-2015

Re: SDK 2016.2 getting stuck in "Initializing s/w repositories" stage

Jump to solution

Hi @kharobangdo,

 

No sure how windows is working so I would try directly lauching SDK as admin.

 

Could you also check the proxy settings in SDK. Try to set it to direct. It has helped to solve some weird issues


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Adventurer
Adventurer
1,008 Views
Registered: ‎12-25-2014

Re: SDK 2016.2 getting stuck in "Initializing s/w repositories" stage

Jump to solution
I tried the proxy settings you suggested but it didn't affect anything. Initializing s/w repositories was still taking forever. So, once I it was over & s/w repositories were finally initialized, I removed C:\Xilinx from Global repositories. Now, SDK doesn't get stuck every time I launch it. That temporary solution is OK for me as of now