UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
419 Views
Registered: ‎03-08-2018

SDK Building Issue

Hi,

                    I am working one of the Video Processing application project and using the Vivado 2018.1 and SDK 2018.1. The Vivado design contains PS+PL part and targeted board is ZC702. I had to add some image processing IP stage by stage. Instead of create new project again, I copied the base design and added some image processing IP.After i regenerated bit stream, the HW was imported into SDK to develop application.

 

For example

Base design  

Base design1

Base design2

Base design3

Base design4

 

All the design has same TPG path.

 

The base design , base design1 and base design2 was working fine.

But i am facing some issues in the base design3 and base design4.

 

Case 1;

If i download the bit stream and .elf of the base design3 or base design4 into the board, there was no video output on the monitor.but in UART console I2C init and I2C Transaction is fine and Video IP init and configuration is fine.

 

Case 2:

But if i download the bit stream of  the base design3 and base design4, and the .elf of the base design , base design1 and base design2, the design was working fine without any issue.

 

Case 3:

If i download the bit stream of the base design ,base design1 and base design2 and the .elf of the base design3 and base design4, the design wasn't working.

 

It seems that the base design3 and base design4 has building issue.

 

I have done only small changes between this base designs.

 

what could be a problem?

 

Thanks,

Kannan

0 Kudos
2 Replies
Moderator
Moderator
362 Views
Registered: ‎10-06-2016

Re: SDK Building Issue

Hi @kannan,

It seems that you are adding IPs in your Vivado design but what is not clear is what kind of application are you developing and the differences within the base designs.

As you said the issue seems to be in the design3/4 application, so take a look the differences.

Regards
Ibai

Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos
Adventurer
Adventurer
338 Views
Registered: ‎03-08-2018

Re: SDK Building Issue

Hi,

 

In the block design ,           

               ctrl_clk is a AXI Lite clock (50MHz)

               clk200 is a VDMA Clock (200MHz)

               pclk_0 is a pixel clock (8MHz) of the camera

               vid_out_clk is a video resolution clock (which depends on the output resolution) . Ex : For HD resolution (74.25MHz)

               core_clk is video processing clock to all Video Processing IP.

Thanks,

kannan

0 Kudos