UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer bsutin
Observer
2,164 Views
Registered: ‎04-08-2009

SDK: Debug Output & SIGUSR2

Jump to solution

I've just got my IP core working using EDK 10.1.  Now I am trying to run programs using Debug on Hardware in the SDK. The homegrown flash bootloader proves that it works fine by blinking the onboard LED's. TestApp_Memory and TestApp_Peripheral both hang up waiting for the UART (connected to module_debug). Do I have to connect the module_debug STDOUT to an SDK window, and if so, how do I do that in EDK 10.1?

 

The main program I want to run gives the error, "Can't send signals to this remote system.   SIGUSR2 not sent."  This program was added to the SDK and installed the same way as the bootloader.  Thanks for any tips!

 

Brian

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Observer bsutin
Observer
2,675 Views
Registered: ‎04-08-2009

Re: SDK: Debug Output & SIGUSR2

Jump to solution

I found the answer to the stdout/console issue here:

 

    http://forums.xilinx.com/t5/Xilinx-Boards-and-Kits/JTAG-UART-console-on-ML507-development-board/td-p/69824

 

TestApp_Peripheral gives the same SIGUSR2 error.  Maybe it has something to do with using DDR2 memory?

View solution in original post

0 Kudos
1 Reply
Highlighted
Observer bsutin
Observer
2,676 Views
Registered: ‎04-08-2009

Re: SDK: Debug Output & SIGUSR2

Jump to solution

I found the answer to the stdout/console issue here:

 

    http://forums.xilinx.com/t5/Xilinx-Boards-and-Kits/JTAG-UART-console-on-ML507-development-board/td-p/69824

 

TestApp_Peripheral gives the same SIGUSR2 error.  Maybe it has something to do with using DDR2 memory?

View solution in original post

0 Kudos