UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer egger006
Observer
3,325 Views
Registered: ‎09-18-2013

SDK - GDB crashes all the time!

Hi!

 

I'm on a ZedBoard (Zynq7020), got some OO design in C++, and GDB won't stop crashing (mostly when stepping / running into breakpoints).

 

Downloading works fine, but at some point, after stepping into and out of some functions/methods, GDB delivers following (or similar) error message(s):

 

15:40:57 ERROR    : Unexpected error while launching program.
java.lang.RuntimeException: Target request failed: Cannot access memory at address 0x10e364.
    at com.xilinx.sdk.debug.core.XilinxAppLaunchConfigurationDelegate.debugApplication(XilinxAppLaunchConfigurationDelegate.java:706)
    at com.xilinx.sdk.debug.core.XilinxAppLaunchConfigurationDelegate.launch(XilinxAppLaunchConfigurationDelegate.java:253)
    at com.xilinx.sdk.debug.ui.XilinxAppLaunchDelegateWrapper.launch(XilinxAppLaunchDelegateWrapper.java:31)
    at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:855)
    at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:704)
    at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:1047)
    at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1251)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

 

...and Windows (7, 64 bit) says "arm-xilinx-eabi-gdb.exe has stopped working...".

 

Also, before crashing, it happens very often that I can't access Expressions and view my variable contents in the Eclipse/SDK GUI. It might be that these two bugs have something to do with each other. Both are really annoying, I can say that.

 

I tried removing -std=c++11 flag, no change. Also, I have -O0 and -g3 activated.

 

Enough stack and heap size should be assigned (a few megabytes each, if GDB even needs it, I don't know...).

 

I tried upgrading from SDK 2013.4 to 2014.1, no change at all.

 

Sometimes, when changing smaller code segments, I can watch the contents of my Variables and Expressions when stepping, and GDB crashes at a later time, or earlier, or not. I could not find a pattern there...

 

Thanks in advance and best regards,

 

Stefan

0 Kudos
2 Replies
Observer egger006
Observer
3,310 Views
Registered: ‎09-18-2013

Re: SDK - GDB crashes all the time!

small update: i managed to get a different error message in the Console window of the SDK:

 

/scratch/janisjo/build3/2013.11-xilinx-eabi-release/obj/gdb-src-2013.11-46-arm-xilinx-eabi-i686-mingw32/gdb/infrun.c:1965: internal-error: resume: Assertion `pc_in_thread_step_range (pc, tp)' failed.
A problem internal to GDB has been detected,
further debugging may prove unreliable.This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

 

this is looking highly buggy, along with a thousand other things in the xilinx toolchain... i'm soriously thinking about stepping away from it, it's only been troubling so far.

0 Kudos
Xilinx Employee
Xilinx Employee
3,293 Views
Registered: ‎08-02-2007

Re: SDK - GDB crashes all the time!

Hi,

 

Would that be possible to use System Debugger?

 

There are a few known issues with the SDK GDB debugger as mentioned in the below link

 

http://www.xilinx.com/support/documentation/sw_manuals/xilinx14_6/SDK_Doc/tasks/sdk_t_tcf_limitations_faq.htm

 

--Hem

 

 

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos