cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
4,141 Views
Registered: ‎06-25-2008

SDK Is Not Generating Drivers

SDK is not generating my xiic drivers now when it did before I updated to 13.4.  I noticed that the MSS had the iic cores driver version blank and there is no generated .c .h files.  Does anyone know why this happens? 

0 Kudos
4 Replies
Moderator
Moderator
4,140 Views
Registered: ‎09-12-2007

in bsp (board support package ) settings can you add the driver here? To get this in Xilinx Tools -> board support package settings. Change this from generic to iic driver.

 

If this is not here, can you make sure that the hardware is connected correctly in EDK, bus, ports, address space, ect. The libgen used the XML file to comile the drivers. The XML file is created when exported from wdk to sdk uisng the MHS file.

0 Kudos
Highlighted
Explorer
Explorer
4,134 Views
Registered: ‎06-25-2008

Thanks for the reply.  Before the upgrade to 13.4 the files were being generated so any idea what could have happened?

0 Kudos
Highlighted
Moderator
Moderator
4,125 Views
Registered: ‎09-12-2007

ust some background into the SDK. When, exporting ffrom XPS to SDK, A tool call psf2edward runs. This will take the MHS file, and create an XML file. This XML file is used in Libgen, which will compile your drivers, ect..

 

So, if the MHS is not correct, the XML will not be correct, ect.. so this is worth checking. Also, have you checked the BSP setting t omake sure that you can select the iic driver?

0 Kudos
Highlighted
Explorer
Explorer
4,123 Views
Registered: ‎06-25-2008

I think EDK/SDK screwed itself up with the uprgade from 13.1 - 13.4 since nothing was making sense.  I started a new project with the exact same MHS file and now it is working fine (with the exception that SDK won't load the FPGA but EDK will).

0 Kudos