UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Scholar beandigital
Scholar
687 Views
Registered: ‎04-27-2010

SDK cant set a breakpoint in a Xilinx file

Jump to solution

I am trying to debug a serial flash file in SDK 2018.1. When I place a breakpoint I get the error shown below. Does anyone know how to resolve this? Thanks

 

Untitled.png

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
806 Views
Registered: ‎10-21-2010

回复: SDK cant set a breakpoint in a Xilinx file

Jump to solution

The code you're referring to is part of BSP, which is built with optimizations enabled. To debug this code, you need to disable optimizations. In BSP settings dialog, click on the CPU driver from left side pane, and add "-O0 -g3" to extra_compiler_flags. Rebuild the BSP, and then you should be able to debug the code you're referring to

3 Replies
Explorer
Explorer
674 Views
Registered: ‎07-17-2014

回复: SDK cant set a breakpoint in a Xilinx file

Jump to solution

hi @beandigital
i've had a similar problem. I don't know how to solve this problem.

But you can print out the data that you want to see through the serial port so as to avoid the above problem.

0 Kudos
Scholar beandigital
Scholar
664 Views
Registered: ‎04-27-2010

回复: SDK cant set a breakpoint in a Xilinx file

Jump to solution
Thanks for the info. But it would be good to be able to debug the code!
0 Kudos
Xilinx Employee
Xilinx Employee
807 Views
Registered: ‎10-21-2010

回复: SDK cant set a breakpoint in a Xilinx file

Jump to solution

The code you're referring to is part of BSP, which is built with optimizations enabled. To debug this code, you need to disable optimizations. In BSP settings dialog, click on the CPU driver from left side pane, and add "-O0 -g3" to extra_compiler_flags. Rebuild the BSP, and then you should be able to debug the code you're referring to