UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
5,221 Views
Registered: ‎03-23-2015

SDK linked source file error "No such file"

Jump to solution

Tool  : SDK 

Version: 2015.2

 

Hi all,

  I have a SDK project that can compile without error.  Then I try to move some .c and .h files to a directory outside of workspace and link the files back into SRC folder for compile.  I followed the method New -> File -> Advance -> Link to File in the File System.  I did not use the Variable button.

  So I can see the linked files in project explorer (with arrows)

 

Capture.PNG

 

However, upon Build, I get the errors:

 

arm-xilinx-eabi-gcc -Wall -O0 -g3 -IC:/share/hdl-2015_r2_neo/projects/pzsdr/xil_dma_hdl_opti/xil_dma_hdl_opti.sdk/system_top_hw_platform_2_bsp_lwip/ps7_cortexa9_0/include -c -fmessage-length=0 -MT"src/dac_core_intr.o" -MMD -MP -MF"src/dac_core_intr.d" -MT"src/dac_core_intr.d" -o "src/dac_core_intr.o" "../src/dac_core_intr.c"
../src/dac_core_intr.c:51:22: fatal error: comm_api.h: No such file or directory
#include "comm_api.h"
^

 

Please advise how can I get this to work.

 

Thanks,

 

Neo

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
8,816 Views
Registered: ‎10-06-2016

Re: SDK linked source file error "No such file"

Jump to solution

Hi @wtneo

 

The issue you are facing is regarding the compiler include paths, I mean, although your are able to see your linked files in the SDK project the compiler is not able to find them in the src folder because these are not located there.

 

If using linked files in the project, you have to add the folder where these linked files are located in the project settings. You can do it both by using absolute path or relative paths.Take into account that it also a requirement to add the src folder path also to the compiler include paths, because when compiling the linked c files you may have some header files in the project src location.

 

Capture.PNG

 

I will also suggest the usage of linked folders rather than the linked files rather than linking files one by one ;)


Ibai
Don’t forget to reply, kudo, and accept as solution.
3 Replies
Moderator
Moderator
8,817 Views
Registered: ‎10-06-2016

Re: SDK linked source file error "No such file"

Jump to solution

Hi @wtneo

 

The issue you are facing is regarding the compiler include paths, I mean, although your are able to see your linked files in the SDK project the compiler is not able to find them in the src folder because these are not located there.

 

If using linked files in the project, you have to add the folder where these linked files are located in the project settings. You can do it both by using absolute path or relative paths.Take into account that it also a requirement to add the src folder path also to the compiler include paths, because when compiling the linked c files you may have some header files in the project src location.

 

Capture.PNG

 

I will also suggest the usage of linked folders rather than the linked files rather than linking files one by one ;)


Ibai
Don’t forget to reply, kudo, and accept as solution.
Adventurer
Adventurer
5,180 Views
Registered: ‎03-23-2015

Re: SDK linked source file error "No such file"

Jump to solution

Hi ibaie,

  That worked!

 

  Tks.

 

Neo

 

0 Kudos
Observer thammer
Observer
1,094 Views
Registered: ‎10-09-2018

Re: SDK linked source file error "No such file"

Jump to solution

 

I am using SDK 2017.2 to build binaries for a ZCU102 board using a custom hardware definition. One of the applications is built using a FreeRTOS BSP for one core while another application is built using a standalone BSP for a different core.

For purposes of this post, I am only working on the FreeRTOS-based application if it makes any difference.

I thought that the linked file situation was as @ibaie describes it, but was experimenting and found that I was able to reference header files that are in a virtual folder that is in the src/ directory of my project. This worked for two different virtual folders.

But now that I am attempting a third, it is not working. What is even more frustrating is that when I add an entry in Properties --> C/C++ Build --> Settings --> Directories (Include Paths), it does not show up on the command line shown in the Console output when it reports the error!

If I look back in Properties --> C/C++ Build --> Settings --> ARM A53 gcc compiler at the "All options:" field, it is there- why does it not get to the actual command line?!?!?

Any thoughts/ideas?

Thanks!
.Tim

 

0 Kudos