UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Participant pgielmuda
Participant
968 Views
Registered: ‎10-18-2017

SDK not responding while creating example OpenAMP application

I'm using SDK 2017.3 for half a year. I have UltraZed PCIe Carrier Card for testing purpose. All of example projects were created without any problems. However when I tried to create example project associated with OpenAMP framework SDK stops working (not responding). 

 

Here is a details of steps that I'm taking:

1. I create very simple Vivado project with SPI Quad IPCore included. I generate bitstream and export it as usuall. 

2. I lunch the SDK (workspace local to vivado project). Logs inform that everything is fine:

11:09:36 INFO : Registering command handlers for SDK TCF services
11:09:37 INFO : Launching XSCT server: xsct.bat -interactive C:\Xilinx\my_prj\CS_SPI_double_buffered\CS_SPI_double_buffered.sdk\temp_xsdb_launch_script.tcl
11:09:46 INFO : XSCT server has started successfully.
11:10:26 INFO : Successfully done setting XSCT server connection channel
11:10:26 INFO : Successfully done setting SDK workspace
11:10:26 INFO : Processing command line option -hwspec C:/Xilinx/my_prj/CS_SPI_double_buffered/CS_SPI_double_buffered.sdk/design_1_wrapper.hdf.
11:10:26 INFO : Checking for hwspec changes in the project design_1_wrapper_hw_platform_1.
11:10:26 INFO : ***** MYVIVADO is set to 'C:\Xilinx\Vivado\2017.3' *****

3. I create new project by choosing File -> New -> Application project

4. I set up project properties as in attachment 1.
5. I click next and on the next page I choose one of the fallowing projects:
- Libmetal AMP Application

- OpenAMP echo-test application 

6. I click finish and wait... My record was to wait for 2hours. Nothing happened- the SDK is not responding and I need to kill the process. 

 

Any clue what I could do wrong here?

SDK_setup.PNG
0 Kudos
4 Replies
Xilinx Employee
Xilinx Employee
948 Views
Registered: ‎10-21-2010

Re: SDK not responding while creating example OpenAMP application

Hi,

Can you please post SDK trace here? You can enable the trace log but clicking on 'Open SDK Log Preferences' icon which is at the top right corner of the SDK log view.

 

Also, you seem to be using some patch thru MYVIVADO env variable. What patch is this? Can you unset MYVIVADO and try?

 

Additionally, can you provide a hdf to reproduce this issue?

0 Kudos
Participant pgielmuda
Participant
938 Views
Registered: ‎10-18-2017

Re: SDK not responding while creating example OpenAMP application

I disable MYVIVADO env variable. I also enable trace log. 

In the attachment you can find two log dump:

- from startup of SDK (without some first few lines with PATH print). Name of file: Startup_without_MYVIVADO.txt

- from creating OpenAMP echo-test project (this is dump just before clicking finish on New project window- after that SDK crashes) Name of file: Log_MYVIVADO_unset.txt

 

I'm worried about this log from startup dump:
(XSDB Server)CRITICAL WARNING: [Board 49-71] The board_part definition was not found for em.avnet.com:ultrazed_eg_pciecc_production:part0:1.0. The project's board_part property was not set, but the project's part property was set to xczu3eg-sfva625-1-i. Valid board_part values can be retrieved with the 'get_board_parts' Tcl command. Check if board.repoPaths parameter is set and the board_part is installed from the tcl app store.

 

I do not have approve to give you my hdf file. However I copy hdf to my colleague PC and try the same on his PC. For him OpenAMP echo-test project was created successfully. He has Vivado 2017.1. I think I will reinstall my Vivado to that version I try it once again. 

 

If you will have any clue what is wrong based on log dump do not hesitate to answer ;). 

0 Kudos
Visitor m_takashima
Visitor
789 Views
Registered: ‎03-27-2018

Re: SDK not responding while creating example OpenAMP application

I faced the very similar problem with OpenAMP echo-test application project creation.
I use Xilinx SDK 2017.4 with Windows 10 Pro 64-bit.

Like pgielmuda did, I tried to create OpenAMP echo-test application, Xilinx SDK froze with no response.
I tried to create another application projects like ZYNQ DRAM tests, it looked like to succeed with no problems.
I re-installed Vivado, but situation didn't change.

When I tried to create OpenAMP application, Xilinx SDK was looked like failing to generate xparameters.h.
And, there is nothing but xparameters.h in include folder.
In correct case, I think there should be many header files in it.

Just FYI, I attached incomplete xparameters.h and .metadata/.log file.
In addition, I attached SDK trace and hdf file (zip archived).

Could you give me some advises to resolve this problems? Thanks!

0 Kudos
278 Views
Registered: ‎02-11-2014

Re: SDK not responding while creating example OpenAMP application

Any more info on this? I am having the same issue.

Any (r5) libmetal/openAmp demo application created in SDK results in a hang in the "New Project" dialog. But other r5 standalone apps work. The hang seems to happen while creating the BSP (the bsp folder is in the .sdk folder, but not the application).

I created a separate standalone r5 BSP and enabled only libmetal and openAmp libraries. It completed. But when I clicked on it (in "Project Explorer"), in the hopes of build it, the SDK hung (not responding).

0 Kudos