cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
arrilag
Visitor
Visitor
1,315 Views
Registered: ‎03-01-2018

SDK not showing in BSP axi_iic_0

Jump to solution

Hi 

I am using Vivado 2017 and Xilinx SDK 2017.4 with a Zedboard.

In my Vivado block design I had first the ZYNQ configured with I2C-0 and I2C-1 outputs. But then I decided to remove I2C-0 from the ZYNQ and added axi_iic_0 to my design and set its pins to H15 and K15 (1.8V).

However when I open Xilinx SDK with the C-code I wrote earlier, I still see in the Board Support Package ps7_i2c_0 and ps7_i2c_1 with options to import examples, but no axi_iic..

 

I suspect I messed up the file-structure of my design.

I also tried "Re-generate BSP Sources" but no change...

How do I update the references so that SDK shows me the BSP that belongs to my new hardware design?

Thanks for any help.

0 Kudos
1 Solution

Accepted Solutions
arrilag
Visitor
Visitor
1,593 Views
Registered: ‎03-01-2018

ok, following this post I added an interrupt controller to the design (axi_intc_0) and that fixed the "fatal error: xintc.h".

I guess that solved my problem.

Thanks

View solution in original post

0 Kudos
4 Replies
watari
Teacher
Teacher
1,310 Views
Registered: ‎06-16-2013

Hi @arrilag

 

Did you export hardware design file into SDK, again ?

If no, would you try it ?

 

Best regards,

0 Kudos
arrilag
Visitor
Visitor
1,299 Views
Registered: ‎03-01-2018

Hi @watari

 

Thank you for the quick reply.

I exported the bitstream and re-launched SDK, but still same situation (please see below screenshot):

- I see ps7_i2c_0 and ps7_i2c_1

- no axi_iic even though I have it in the block-design.

 

iic.gif
0 Kudos
arrilag
Visitor
Visitor
1,288 Views
Registered: ‎03-01-2018

now I removed ZYNQ and axi_iic from my block-design, put 'new' ZYNQ and axi_iic in the design and recofigured them, then re-ran bit generation, exported the bitstream and opened up a new Application Project in SDK... and now I see the updated BSP with only ps7_i2c_1 and axi_iic_0.

But trying now the xiic_multi_master_example I get the error 

../src/xiic_multi_master_example.c:111:19: fatal error: xintc.h: No such file or directory

 

Thanks for any hint how this can be solved.

 

 

0 Kudos
arrilag
Visitor
Visitor
1,594 Views
Registered: ‎03-01-2018

ok, following this post I added an interrupt controller to the design (axi_intc_0) and that fixed the "fatal error: xintc.h".

I guess that solved my problem.

Thanks

View solution in original post

0 Kudos