UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor ri_le
Visitor
13,838 Views
Registered: ‎03-04-2013

SDK port number for Linux

Hi all,

 

I'm trying to run the hello world program (UG873 tutorial) using SDK(v14.4) on the Zynq board (ZC702 Evaluation Kit).

The Jtag cable and USB cable are plugged to the Linux host computer and cp210x is installed.

I know the new port connected is ttyUSB0 (In Windows, the connected port is COM3 or whichever COM number the host machine assigns)

 

However the SDK tells me the following when I try to connect to the port using the terminal:

No such port: 'ttyUSB0'

 

I searched online and used lsusb to see my usb connections, but I still don't know how to connect to the board:

 

# /usr/sbin/lsusb
Bus 002 Device 007: ID 10c4:ea60 Cygnal Integrated Products, Inc. CP210x Composite Device
Bus 002 Device 004: ID 03fd:0013 Xilinx, Inc.
Bus 002 Device 003: ID 18e3:9106 Fitipower Integrated Technology Inc
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0461:4d81 Primax Electronics, Ltd
Bus 001 Device 003: ID 413c:2107 Dell Computer Corp.
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

# dmesg | tail
usb 2-1.4: new full speed USB device using ehci_hcd and address 7
usb 2-1.4: New USB device found, idVendor=10c4, idProduct=ea60
usb 2-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 2-1.4: Product: CP2103 USB to UART Bridge Controller
usb 2-1.4: Manufacturer: Silicon Labs
usb 2-1.4: SerialNumber: 0001
usb 2-1.4: configuration #1 chosen from 1 choice
cp210x 2-1.4:1.0: cp210x converter detected
usb 2-1.4: reset full speed USB device using ehci_hcd and address 7
usb 2-1.4: cp210x converter now attached to ttyUSB0

 
Any suggestions?

 

Thanks in advance

4 Replies
Visitor tjloftus57
Visitor
12,828 Views
Registered: ‎02-28-2015

Re: SDK port number for Linux

Perhaps someone with support could ask and post the answer to this or at least confirm it is possible or not?

I notice over 1000 people have viewed it, so it seems a common question.

 

Just like the OP I have tried various tty port designations and nothing works, just keep getting "No such port".

 

 

0 Kudos
Visitor tjloftus57
Visitor
12,825 Views
Registered: ‎02-28-2015

Re: SDK port number for Linux

Some more information, at least on my Centos 6.6 system to identify port info:

 

Relevant output from lsusb for USB UART device on Zedboard (J14)

$ lsusb
...
Bus 002 Device 009: ID 04b4:0008 Cypress Semiconductor Corp. 
$ 

 Relevant info from dmesg where you can see the device ID and the assigned string ttyACM0:

usb 2-2.2: new full speed USB device number 9 using uhci_hcd
usb 2-2.2: New USB device found, idVendor=04b4, idProduct=0008
usb 2-2.2: New USB device strings: Mfr=1, Product=2, SerialNumber=4
usb 2-2.2: Product: Cypress-USB2UART-Ver1.0G
usb 2-2.2: Manufacturer: 2012 Cypress Semiconductor
usb 2-2.2: SerialNumber: 8410A3D80C12
usb 2-2.2: configuration #1 chosen from 1 choice
cdc_acm 2-2.2:1.0: This device cannot do calls on its own. It is not a modem.
cdc_acm 2-2.2:1.0: ttyACM0: USB ACM device

 Next, I noticed permissions on this device required the user to be in the "dialout" group:

$ ls -al /dev/ttyACM0
crw-rw----. 1 root dialout 166, 0 Mar  4 21:11 /dev/ttyACM0
$ 

 So I added my username to the "dialout" group using the "system-config-users" utility.  I then logged out and back in and made sure my active terminal sessions and vivado processes had been restarted with the new group membership.

$ id -Gn
users dialout
$

 

Finally, I entered the "port" in Vivado SDK Terminal settings dialog as "/dev/ttyACM0" and it no longer gave the "No such port" message.

 

Unfortunately, as soon as I hit "Enter" or tried to get a prompt from the zedboard, the SDK (java) crashes.

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f49c2ad7a6a, pid=83898, tid=139956509259520
#
# JRE version: Java(TM) SE Runtime Environment (8.0_05-b13) (build 1.8.0_05-b13)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.5-b02 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [librxtxSerial.so+0x7a6a]  Java_gnu_io_RXTXPort_nativeDrain+0xea

 So if anyone has any ideas how to fix this java rxtx failure, it just might work.

 

0 Kudos
Highlighted
Visitor tjloftus57
Visitor
12,811 Views
Registered: ‎02-28-2015

Re: SDK port number for Linux

Continuing to search for a solution to this terminal window java crash, but so far most of the threads I have come across either have no solution or end with workarounds using a terminal program outside the XSDK instead of the integrated terminal.  Some suggest minicom which I found kind of cumbersome to use.  Another useful blog here suggests gtkterm:

 

http://svenand.blogdrive.com/archive/173.html#.VPiqH4F4p90

 

Rather than spend more time on trying to figure out the java crash issue, I guess I too will use gtkterm in a separate window and move on.

 

0 Kudos
Visitor mjbarrow
Visitor
11,548 Views
Registered: ‎06-19-2015

Re: SDK port number for Linux

Hi, there is a fix for this as noted here:

 

but I'll re-state it to clear some clarification on that post

 

Assuming a 64 bit Ubuntu (3.16 generic)

 

add yourself to the dialout group

download the RxTx source, version 2.2pre

build it with locks disabled

replace all of the librxtx libraries in the SDK folder with your new ones

 

or to say it another way

 

open a terminal

1: sudo gpasswd --add YOUR_USERNAME dialout

2: sudo chmod 777 /var/lock

2: cd ~ && wget http://rxtx.qbang.org/pub/rxtx/rxtx-2.2pre2.zip && unzip rxtx-2.2pre2.zip && cd rxtx-2.2pre2

3: ./configure --disable-lockfiles

4: make

DO NOT WORRY ABOUT THE BUILD ERRORS

5: cd /opt/Xilinx/14.7/ISE_DS/EDK/eclipse/lin64/eclipse/plugins/gnu.io.rxtx.linux.x86_64_2.1.7.3_v20071015/os/linux/x86_64

6: sudo mv librxtxParallel.so librxtxParallel.so.orig

7: sudo mv librxtxSerial-2.1-7.so librxtxSerial-2.1-7.so.orig

8: sudo mv librxtxSerial.so librxtxSerial.so.orig

9: sudo ln ~/rxtx-2.2pre2/x86_64-unknown-linux-gnu/.libs/librxtxParallel.so ./librxtxParallel.so

10: sudo ln ~/rxtx-2.2pre2/x86_64-unknown-linux-gnu/.libs/librxtxSerial-2.2pre1.so ./librxtxSerial-2.2pre1.so

11: sudo ln ~/workspace/rxtx-2.2pre2/x86_64-unknown-linux-gnu/.libs/librxtxSerial.so ./librxtxSerial.so

 

Now, open the xilinx SDK an Configure the terminal like so:

 

Port /dev/ttyUSB0

Baud Rate 9600

 

Full settings are shown in the attachment.

 

After connecting, you should see a flashing black cursor in the terminal window.

 

good luck!

termsettings.png
0 Kudos