UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor
Contributor
7,157 Views
Registered: ‎05-28-2014

SDK tool problem

Hi 

I am working on XilinxSDK-2014.2 tool and targeting  on Zynq7020 and trying to communicate with the device using the I2C interface. The generated code is working fine, but whenever i build it the code is not working. Even the same code is not working if i create the new project and use the same code along with the same HDF file. 

  Can anybody please tell me what would be the problem.

 

Regards

0 Kudos
8 Replies
Scholar sampatd
Scholar
7,153 Views
Registered: ‎09-05-2011

Re: SDK tool problem

Is there any error you see while building the project in SDK?

If so, can you attach the error log?
0 Kudos
Xilinx Employee
Xilinx Employee
7,146 Views
Registered: ‎10-24-2013

Re: SDK tool problem

Hi,
Moving to correct board.
Thanks,Vijay
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Xilinx Employee
Xilinx Employee
7,123 Views
Registered: ‎08-02-2007

Re: SDK tool problem

hi,

 

is the existing code based off an older version of driver? what is the application that your code is trying to do?

 

--hem

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Contributor
Contributor
7,110 Views
Registered: ‎05-28-2014

Re: SDK tool problem

Hi ,

 

There are no errors while building

0 Kudos
Contributor
Contributor
7,109 Views
Registered: ‎05-28-2014

Re: SDK tool problem

Hi htsvn,

No, the code is not based on the older version, they are same version.
I am trying to communicate with the peripheral using the I2C, where i am trying to write/read it registers.
0 Kudos
Contributor
Contributor
7,106 Views
Registered: ‎05-28-2014

Re: SDK tool problem

Hi Vijayak

I am trying in the same board, just by building it again and targeting the same board.
0 Kudos
Scholar sampatd
Scholar
7,094 Views
Registered: ‎09-05-2011

Re: SDK tool problem

Have you tested the example code that are provided with the install: You can find them in
<Xilixn Install>\2014.2\data\embeddedsw\XilinxProcessorIPLib\drivers\iicps_v2_3\examples
0 Kudos
Contributor
Contributor
7,025 Views
Registered: ‎05-28-2014

Re: SDK tool problem

Hi vijayak,

i tryed with that code its working fine,but we are  using our custamized code please find the attached copy of the code.

 

thanks you 

0 Kudos