UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
3,155 Views
Registered: ‎10-09-2013

SDK will not build my project any more

I need to change one of my bare metal projects and for some reason it will not build AT ALL! I cannot even clean it. No matter what I try it displays a pop up for a moment but the console window remains empty.  When I check my files in the folder the date hasn't changed from my last build and my changes are obviously not there.

 

I tried to rebuild the project by creating a new one with a different name and then copying the files over.  That will build but WON'T RUN!  I created it using a backup of my files prior to changing them so it should work as before.  Instead the new ELF doesn't work, the original ELF in the original project works just fine but I can't build the original project to implement some changes.  WHAT THE HECK HAPPENED????  All my other projects work fine.  Any clues would be appreciated.

0 Kudos
4 Replies
Community Manager
Community Manager
3,144 Views
Registered: ‎06-14-2012

Re: SDK will not build my project any more

Is this in 2014.2? This seems weird.. Something has locked all the files.

Can you try with a different workspace?

 

Regards

Sikta

0 Kudos
Highlighted
3,142 Views
Registered: ‎10-09-2013

Re: SDK will not build my project any more

Yes, this is with 2014.2.  I haven't tried another workspace.  I'm kind of reluctant to do that since that will violate our configuration management process.

0 Kudos
3,139 Views
Registered: ‎10-09-2013

Re: SDK will not build my project any more

OK, well it seems that the build settings on my project somehow was changed. The "Build on resource save (Auto build)" and "Build (Incremental build)" on the C/C++ Build Behavior tab were grayed out for my project and when I created the new project those settings became the default. Don't know how because those are options I want and I didn't even know those options were on that tab. What a nightmare this has been. SDK 2013.2 was buggy so we updated to 2014.2 only to find it is even MORE buggy. Not a good trade. Doubt I will be brave enough to use 2014.3 based on my experience so far...
0 Kudos
Xilinx Employee
Xilinx Employee
3,136 Views
Registered: ‎07-01-2010

Re: SDK will not build my project any more

Moving this to Embedded board
---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------
0 Kudos