cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
su.li@bd.com
Observer
Observer
2,451 Views
Registered: ‎10-18-2018

Standard header files not found

Jump to solution

When I created a C++ project and include some standard header files, such as iostream, fstream, stdio.h and iostream etc. I have the similar problem as this post:

https://forums.xilinx.com/t5/Embedded-Processor-System-Design/SDK-can-not-find-header-files/td-p/562757

and tried the given suggestions. I also added the path C:\Xilinx\SDK\2018.2\gnu\aarch32\nt\gcc-arm-linux-gnueabi\arm-linux-gnueabihf\include\c++\7.2.1\tr1  but still shows the warning signs(see screen shot). Any one has a complete solution to resolve the issue? Thanks in advance!

IncludeIssue.JPG
0 Kudos
1 Solution

Accepted Solutions
su.li@bd.com
Observer
Observer
2,355 Views
Registered: ‎10-18-2018

Actually after I checked GCC Build-in Compiler Settings Cross ARM, it works ok. 

View solution in original post

0 Kudos
2 Replies
ibaie
Xilinx Employee
Xilinx Employee
2,374 Views
Registered: ‎10-06-2016

Hi su.li@bd.com,

You need to set the include folder path within the project settings.

image.png

Once done the path should be listed within the project include directories and if the correct path the include statements should not be marked as non resolved.

image.png

Regards


Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos
su.li@bd.com
Observer
Observer
2,356 Views
Registered: ‎10-18-2018

Actually after I checked GCC Build-in Compiler Settings Cross ARM, it works ok. 

View solution in original post

0 Kudos