cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
gusevv
Adventurer
Adventurer
4,288 Views
Registered: ‎11-13-2008

The XPS neither keeps Recent Projects history nor opens XMP files from command line (Linux)

Jump to solution

Hi,

 

I am running XPS tools on Linux. There is a problem with opening projects from command line or using File->Recent Projects. The command line (i.e. xps system.xmp &) results in the GUI opened with a typical New Project window showing BSB, blank and recent project options. The latter does not have any history.

 

Similarly, when using a File->Recent Projects menu in GUI, the list is empty. What could be the problem?

 

Tools:

- EDK 9.2.4i

 

Thank you,

Victor

 

 

0 Kudos
1 Solution

Accepted Solutions
nfogh
Contributor
Contributor
5,352 Views
Registered: ‎02-12-2009
Try to check if the xilinxrc file under the .qt directory is read/writable by you. When I changed it from owner root to myself, the "recent projects" problem disappeared for me.

View solution in original post

4 Replies
nfogh
Contributor
Contributor
4,276 Views
Registered: ‎02-12-2009
Have you checked your permissions for the ~/.qt and ~/.Xilinx directory? I had the same problem because i didn't have write access to the files in these directories.
gusevv
Adventurer
Adventurer
4,273 Views
Registered: ‎11-13-2008

$ ls -al ~/

drwxr-xr-x 2 victor victor 4096 2009-11-24 00:40 .qt

drwxr-xr-x 2 root root 4096 2009-07-07 22:21 .Xilinx

 

The latter one contains only a license file. I changed permissions, but not the owner for the folder only:

$ sudo chmod ugo+w ~/.Xilinx

$ ls -al ~/

drwxr-xr-x 2 victor victor 4096 2009-11-24 00:40 .qt

drwxrwxrwx 2 root root 4096 2009-07-07 22:21 .Xilinx

 

Still the same problem:

$ xps system.xmp &

results in the new project window instead of opening the project. The history is not kept either. 

 

Did I miss anything?

 

I wanted to run the tools as root (i.e. $sudo xps), but it complained about not knowing where xps is. I tried before setting environment variables to point to the right installation paths the same way for root as for my user, but it did not work. 

 

Thanks,

Victor

 

 

 

 

0 Kudos
nfogh
Contributor
Contributor
5,353 Views
Registered: ‎02-12-2009
Try to check if the xilinxrc file under the .qt directory is read/writable by you. When I changed it from owner root to myself, the "recent projects" problem disappeared for me.

View solution in original post

gusevv
Adventurer
Adventurer
4,247 Views
Registered: ‎11-13-2008
Thanks, it solved the problem!
0 Kudos