UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor pirpirin
Visitor
8,051 Views

Unable to execute XPS (14.7) in CentOS 7

Hi everyone,

 

I am installing Xilinx ISE 14.7 System Edition in CentOS 7.

 

The installation process completes without a problem and after the installation I am able to execute ise and xsdk. However when I try to execute the xps, (I type xps & ), the only thing that opens is the editor for vhdl files. Nothing else.

 

I cannot understand what is the problem or why this is happening. Can you elaborate?

 

Thank you in advance,

Andreas

0 Kudos
5 Replies
Xilinx Employee
Xilinx Employee
8,033 Views

Re: Unable to execute XPS (14.7) in CentOS 7

Hello Andreas,

 

First of all, Cent OS 7 is an unsupported with Xilinx ISE tools. 

See the section "Operating systems" in the following user guide: http://www.xilinx.com/support/documentation/sw_manuals/xilinx14_7/irn.pdf

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Scholar dwisehart
Scholar
8,029 Views

Re: Unable to execute XPS (14.7) in CentOS 7

Probably it needs some packages you do not have installed.  I did not install XPS on my 64-bit Centos 6.6 system so I cannot check which libraries are used, but try this:

 

locate xps

file path/xps

ldd path/xps

 

So if I do this with 'docnav', which I do have I see:

 

$ locate docnav
/opt/Xilinx/.xinstall/payload/2014.1/docnav_0001_2014.1_0405_1.xz
/opt/Xilinx/.xinstall/payload/2014.1/docnav_0003_2014.1_0405_1.xz
/opt/Xilinx/DocNav/docnav
/opt/Xilinx/DocNav/.xinstall/mnf/docnav_0001.mnf
/opt/Xilinx/DocNav/.xinstall/mnf/docnav_0002.mnf
/opt/Xilinx/DocNav/.xinstall/mnf/docnav_0003.mnf
/opt/Xilinx/DocNav/resources/docnav-dummy-document.pdf
/home/dwisehart/.local/share/data/Xilinx/DocNav/docnav.ini

 

$ file /opt/Xilinx/DocNav/docnav
/opt/Xilinx/DocNav/docnav: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.9, not stripped

 

You can see here that even though I have a 64-bit system, this executable requires the 32-bit packages.

 

$ ldd /opt/Xilinx/DocNav/docnav

linux-gate.so.1 => (0x00d0e000)
libQtWebKit.so.4 => /opt/Xilinx/DocNav/libQtWebKit.so.4 (0xf6057000)
libQtXml.so.4 => /opt/Xilinx/DocNav/libQtXml.so.4 (0x007d9000)
libQtGui.so.4 => /opt/Xilinx/DocNav/libQtGui.so.4 (0xf5542000)
libQtNetwork.so.4 => /opt/Xilinx/DocNav/libQtNetwork.so.4 (0x00bb1000)
libQtCore.so.4 => /opt/Xilinx/DocNav/libQtCore.so.4 (0x0017a000)
libpthread.so.0 => /lib/libpthread.so.0 (0x00da7000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00475000)
libm.so.6 => /lib/libm.so.6 (0x00560000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x0058a000)
libc.so.6 => /lib/libc.so.6 (0x005a8000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x0073f000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00821000)
libXext.so.6 => /usr/lib/libXext.so.6 (0x00774000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x008b9000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00dee000)
libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0x00dcb000)
libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x009f2000)
libpng12.so.0 => /usr/lib/libpng12.so.0 (0x00786000)
libz.so.1 => /lib/libz.so.1 (0x007ae000)
libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0x00d47000)
libSM.so.6 => /usr/lib/libSM.so.6 (0x007c2000)
libICE.so.6 => /usr/lib/libICE.so.6 (0x00b0f000)
libdl.so.2 => /lib/libdl.so.2 (0x00dc4000)
librt.so.1 => /lib/librt.so.1 (0x00d96000)
/lib/ld-linux.so.2 (0x00b8c000)
libexpat.so.1 => /lib/libexpat.so.1 (0x00b29000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00b51000)
libuuid.so.1 => /lib/libuuid.so.1 (0x00e51000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x00df9000)

 

None of the libraries is missing, which would be a line like:

 

libuuid.so.1 => not found

 

If you have missing libraries, you need to figure out which packages they are in and install those packages.

 

If libraries are not a problem, I suggest running xps with:

 

strace -f -o /tmp/xps.strace.out path/xps

 

After xps starts, shut it back down and then look through the strace output.  It is verbose but you will likely see what it could not find that it should have found.

 

Let us know what you find.  Regards,

Daniel

 

0 Kudos
Visitor pirpirin
Visitor
8,016 Views

Re: Unable to execute XPS (14.7) in CentOS 7

Daniel,

 

thank you very much for your constructive reply.

 

So, I tried what you said. The file command on xps gives the following:

 

$ file xps
xps: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.9, stripped

 

So we are looking at a 64-bit executable.

The ldd command provides the following output:

 

$ ldd xps
linux-vdso.so.1 => (0x00007fff96ffe000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007f2229fc5000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f2229da9000)
libstdc++.so.6 => /lib64/libstdc++.so.6 (0x00007f2229aa1000)
libm.so.6 => /lib64/libm.so.6 (0x00007f222979f000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f2229589000)
libc.so.6 => /lib64/libc.so.6 (0x00007f22291c7000)
/lib64/ld-linux-x86-64.so.2 (0x00007f222a1de000)

 

It seems that everything is in place according to what you wrote me.

 

Now attached is the trace for the xps and for reference the trace for ise that works ok. What I can see in the trace is that there are several "no such file or directory" mesages, but the same is true for ise and it works ok. I am not sure what I am supposed to find in the trace (and it is huge). So if you can elaborate, I would be grateful.

 

Thank you in advance,

Andreas

0 Kudos
Scholar dwisehart
Scholar
8,009 Views

Re: Unable to execute XPS (14.7) in CentOS 7

Hello Andreas,

 

So notice the patterns in the trace files.  The dynamic linker will try to open a file in one location, fail--which means the line with end with = -1 (or another negative number), stat the location and then move on to the next location.  Eventually the open will succeed--which means the line ends with = N where N is the file handle number--and then the file will be fstat, map, read and eventually close.  fstat follows almost every successful open, so if you search the file for fstat's and then look backwards to see if back to the previous fstat there were any open's that failed and were never found.  In the XPS trace I find that libGLU.so.1 was never found, for instance.

 

For Centos, on the command line you enter:

 

yum provides libGLU.so.1

 

which tells me that for 6.6 Centos:

 

mesa-libGLU-10.1.2-2.el6.i686 : Mesa libGLU runtime library
Repo : base
Matched from:
Other : libGLU.so.1

 

So I could then enter:

 

sudo yum install mesa-libGLU-10.1.2-2.el6.i686

 

You are going to have to look through the XPS trace file and see if there are others.  Also, any other return values that are negative (= -N at the end of the line) should be looked into to see if they were resolved.

 

It is a lot of work looking through strace files, but there is a lot of information in there on what is going on.

 

Daniel

 

 

 

0 Kudos
Visitor pirpirin
Visitor
7,993 Views

Re: Unable to execute XPS (14.7) in CentOS 7

Ok I'll try it out.

 

Thanx again!

0 Kudos