cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Observer
Observer
5,059 Views
Registered: ‎02-27-2009

Vivado 2014.2: SDK fails to start when launced to Vivado

Version: Vivado 2014.2

Windows 7 (64 Bit)

 

After exporting my Hardware to SDK, I am getting a Message Window with Title "Eclipse". The message is as follows:

 

"An error has occured. See the log file C:\Projekte\2014\zynq\LED_Controller\LED_Controller.sdk\.metadata\.log."

 

The error messages in this log file are (Full log file attached):

 

java.lang.RuntimeException: Widget disposed too early for part org.eclipse.ui.internal.introview
java.lang.RuntimeException: Widget disposed too early for part com.xilinx.sdk.targetmanager.ui.TargetManagementView
java.lang.RuntimeException: Widget disposed too early for part com.xilinx.sdk.logger.SdkLogView
java.lang.RuntimeException: Widget disposed too early for part org.eclipse.ui.views.ContentOutline
java.lang.RuntimeException: Widget disposed too early for part org.eclipse.ui.views.ProblemView
java.lang.RuntimeException: Widget disposed too early for part org.eclipse.ui.navigator.ProjectExplorer
java.lang.StackOverflowError







 

 

 

java.lang.StackOverflowError

0 Kudos
6 Replies
Highlighted
Xilinx Employee
Xilinx Employee
5,056 Views
Registered: ‎10-24-2013

Hi,

This seems to a crash. Are you seeing this consistently?

Thanks,Vijay
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
Highlighted
Xilinx Employee
Xilinx Employee
5,051 Views
Registered: ‎07-01-2010

Hi,

Are you seeing this when trying to launch SDK from Vivado 2014.2?

If that is the case, can you try to launch the SDK standalone using xsdk from the installation and see if that helps?

Steps:
1.Open command prompt
2.cd to the install c:\Xilinx\SDK\2014.2
3. run .settings64-Software_Development_Kit.bat
4.type xsdk


Regards,
Achutha
---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------
Highlighted
Scholar
Scholar
5,045 Views
Registered: ‎06-14-2012

Hi,

There was a similar issue reported for linux though. I see that you are using Windows.

Can you just check with the workaorund that worked for them?

 

One cause of the problem on Linux has been resolved by removing the .eclipse file from the home directory. 

 

Regards

Sikta

 

 

 

Highlighted
Observer
Observer
5,039 Views
Registered: ‎02-27-2009

Hello,

 

the crash occurs only when launching after exporting the hardware to SDK.

 

When launching SDK for the second time, SDK startup seems to be successful.

 

Thanks,

Rainer

0 Kudos
Highlighted
Observer
Observer
5,032 Views
Registered: ‎02-27-2009

Deleting folder .eclipse does not solve the issue.

0 Kudos
Highlighted
Scholar
Scholar
5,023 Views
Registered: ‎06-14-2012

Can you try with a fresh install? Did any java install or updates happen recently?

From when, did you start getting these errors?

 

Regards

Sikta

0 Kudos