cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
xlpenglearing
Visitor
Visitor
718 Views
Registered: ‎01-28-2021

Vivado 2018.1 SDK - "error launching program: for input string: '1e+08'

Jump to solution

xlpenglearing_0-1611908320686.png

when I downloading *.elf in SDK environment,the sdk show the error. How to solve it???

 

0 Kudos
1 Solution

Accepted Solutions
xlpenglearing
Visitor
Visitor
214 Views
Registered: ‎01-28-2021

Listen to me, I solved this problem.

xlpenglearing_0-1617334981341.png

I find all clock related modules ,such as:

xlpenglearing_1-1617335004910.png

Then,Open the axi_aclk. you will find a error in it.

xlpenglearing_2-1617335107963.png

changed the 1e+08 to 100.

The problem will be been solved.

 

 

View solution in original post

7 Replies
derekm_
Voyager
Voyager
654 Views
Registered: ‎01-16-2019

Hi, @xlpenglearing, you need to share your code to get help with this. Use the "Insert/Edit code sample" feature, as shown:

add_code.png

 

Also, please supply more details on your project (e.g. take a screen shot of the IP Integrator block diagram), tell us what board you are using, boot-mode settings, etc. Does this just happen with one project, or can you get other simple projects to work? Etc, etc.... Thanks!

0 Kudos
xlpenglearing
Visitor
Visitor
593 Views
Registered: ‎01-28-2021

My question is very similar to the one on the website (https://forums.xilinx.com/t5/Embedded-Development-Tools/Vivado-2019-1-3-SDK-quot-error-launching-program-for-input/m-p/1089277)
I just add a system_ila to debug code. In PL program ,I can download .when I use SDK to download *.elf code ,it show  the problem.
some body said the sdk not suppot 1e+08 expression, but In My program,I can not the 1e+08u code . so how the solve the problem?图片1.png

0 Kudos
marcb
Moderator
Moderator
570 Views
Registered: ‎05-08-2012

Hi @xlpenglearing 

Does the below Forums post help? In one case, having the mode pins incorrect has lead to this error.

https://forums.xilinx.com/t5/Embedded-Development-Tools/Error-while-launching-program-For-input-string-quot-5e-07-quot/m-p/968639#M48980

 

 

---------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
---------------------------------------------------------------------------------------------
0 Kudos
stephenm
Moderator
Moderator
562 Views
Registered: ‎09-12-2007

I think the BSP is failing here as the clock is getting incorrectly defined in the xparameters.h file. Can you add the HDF please?

0 Kudos
xlpenglearing
Visitor
Visitor
499 Views
Registered: ‎01-28-2021

This web site:https://forums.xilinx.com/t5/Embedded-Development-Tools/Error-while-launching-program-For-input-string-quot-5e-07-quot/m-p/968639#M48980

It can not solve my problem. MY PL program can be download to FPGA . But use SDK,It is show error.

0 Kudos
xlpenglearing
Visitor
Visitor
346 Views
Registered: ‎01-28-2021

Have other people encountered similar problems?
 I add the hdf,but,It still error.

so ,I update the vivdao2018.1 to  2019?or2020 version?

0 Kudos
xlpenglearing
Visitor
Visitor
215 Views
Registered: ‎01-28-2021

Listen to me, I solved this problem.

xlpenglearing_0-1617334981341.png

I find all clock related modules ,such as:

xlpenglearing_1-1617335004910.png

Then,Open the axi_aclk. you will find a error in it.

xlpenglearing_2-1617335107963.png

changed the 1e+08 to 100.

The problem will be been solved.

 

 

View solution in original post