cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
1,476 Views
Registered: ‎12-26-2016

Vivado won't launch after Windows 10 update

Jump to solution

Hi there,

 

I've got some issues with the Vivado SDK environment. Out of Vivado and from the Windows environment it won't launch. The Crashdump is attached to this post.

 

The last few lines of the logfile (starting at 19882) say that the XMD is somehow broken. I noticed this behaviour this morning after letting the PC run the last updates on friday evening. After this update I'm using Windows 10 Home Version 1803 with OS Build 17134.112. I don't know whether the launch error was made by the update.

 

Besided re-installing the sdk environment what could I do to get back work work? I do not have any system reset points :(

 

Thanks in advance!
Thomas

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Adventurer
Adventurer
1,700 Views
Registered: ‎12-26-2016

Re: Vivado won't launch after Windows 10 update

Jump to solution

Hi @himanshu28

These are the lines of myu TCL script after generating the bit stream:

file copy -force Vivado/FIIR/FIIR.runs/impl_1/design_1_wrapper.sysdef PS_Workspace/FIIR/design_1_wrapper.hdf
launch_sdk -workspace PS_Workspace/FIIR/Workspace -hwspec PS_Workspace/FIIR/design_1_wrapper.hdf

In the PS_Workspace/FIIR/Workspace directory is my sourcecode and the PS_Workspace is in my local git repo. I only checked in my *.c and *h files I created on my own.

This work is for my master thesis and my deadline is in 4 weeks. Changing the whole Vivado environment might be a little risky at the moment for me. If the error occures again I will reheat this topic and contact you directly (too).

Nevertheless changing the export location and the workspace directory worked for me. In future I will only link to the files from eclipse and have the git and working dir separated.

Thanks for the suggesstions!

View solution in original post

0 Kudos
4 Replies
Highlighted
Adventurer
Adventurer
1,468 Views
Registered: ‎12-26-2016

Re: Vivado won't launch after Windows 10 update

Jump to solution

There is something else wrong.

I've changed the workspace directory to an empty one and the sdk starts. I try to get the program back to work and see if the error occurs again.

0 Kudos
Highlighted
Observer
Observer
1,467 Views
Registered: ‎05-17-2018

Re: Vivado won't launch after Windows 10 update

Jump to solution

Hi @tmaintz

Which version of Vivado are you using?

Try installing the latest Vivado version 2018.1 and keep us updated in the feed below.

 

0 Kudos
Highlighted
Adventurer
Adventurer
1,466 Views
Registered: ‎12-26-2016

Re: Vivado won't launch after Windows 10 update

Jump to solution
System is back and running.

I'm using git for version control and the SDK folder is within the repo. Maybe there is an error between git and the xilinx sdk environment.
0 Kudos
Highlighted
Adventurer
Adventurer
1,701 Views
Registered: ‎12-26-2016

Re: Vivado won't launch after Windows 10 update

Jump to solution

Hi @himanshu28

These are the lines of myu TCL script after generating the bit stream:

file copy -force Vivado/FIIR/FIIR.runs/impl_1/design_1_wrapper.sysdef PS_Workspace/FIIR/design_1_wrapper.hdf
launch_sdk -workspace PS_Workspace/FIIR/Workspace -hwspec PS_Workspace/FIIR/design_1_wrapper.hdf

In the PS_Workspace/FIIR/Workspace directory is my sourcecode and the PS_Workspace is in my local git repo. I only checked in my *.c and *h files I created on my own.

This work is for my master thesis and my deadline is in 4 weeks. Changing the whole Vivado environment might be a little risky at the moment for me. If the error occures again I will reheat this topic and contact you directly (too).

Nevertheless changing the export location and the workspace directory worked for me. In future I will only link to the files from eclipse and have the git and working dir separated.

Thanks for the suggesstions!

View solution in original post

0 Kudos