UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer videoswitch
Observer
5,000 Views
Registered: ‎10-22-2014

Why I can't get anything from Zynq UART0??

HI,
   

    I designed a board based on the ZedBoard board. Compare to the Zedboard, I removed the USB port and switched the main serial port from UART1 to UART0 (pin MIO14 & MIO15) for my project. Furthermore, I use a chip named MAX232 connect to the output of pin MIO14 & MIO15 to change the output level. The other parts of my design, such as DDR, SD, QSPI and NETWORK are the same to the design of ZedBoard. The pin of MIO0 is also connect to the GND through a 510 ohm resistor.


    Now, when I run a "Hello Zynq" program generated from ISE tools through Jtag interface, I can get the output message from UART0, and flash the LEDs, such as the pin of MIO7 and MIO49. Moreover, in this work mode, I also can add a user defined "IP CORE", and downloaded the related bit file to the chip to flash other LEDs.

 

    During this process, what I did in ISE tools is very simple. I selected EVM-ZedBoard-7020 as my base hardware configuration, where all the configuration is kept to default value. In "Zynq PS Configuration" dialog box, I firstly disabled the USB0 and UART1, And then I enabled UART0 and allocated MIO14 & MIO15 (pullup is enabled) for this peripheral.


    However, when I run the same program (for the sake of simple, not include any user IP COREs, just operating "PS") from SD card mode. I still can flash the LEDs from the program, but I can't get anying from UART0........why?

    Have I left anything out???
    Any help will be appreciated.
   Thanks a lot!

 

Best Regards,
vs

0 Kudos
1 Reply
Observer videoswitch
Observer
4,986 Views
Registered: ‎10-22-2014

Re: Why I can't get anything from Zynq UART0??

BTW :

 

   I created two projects with the same (zedboard) configuration except UART's by ISE 14.4. I enabled UART0 and disabled UART1 for one project and enabled UART1 and disabled UART0 for another one. After "Exporting SDK", the difference between two ps7_int.c in two projects are :

 

  UART0(MIO14,15) :
     Baud_rate_gen_reg0, 0xE000,0018 = 0x7C,
     UART_CLK_CTRL, 0xF8000154[13:8]=0xA


  UART1(MIO48,49) :
     Baud_rate_gen_reg0, 0xE000,0018 = 0x3E,
     UART_CLK_CTRL, 0xF8000154[13:8]=0x14

 

Is it right ? Need I modify it in ps7_init.c directly?

 

Thanks!

0 Kudos