UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer richnsim
Observer
833 Views
Registered: ‎06-01-2018

(XSDB Server)ERROR: [Hsi 55-1550] Repository Directory ".../drivers" doesn't exist in the disk

Jump to solution

Hi folks,

 

I have a problem with Vivado/SDK 2018.1:

When I want to create a new Hardware Platform Specification I get the error:

 

(XSDB Server)ERROR: [Hsi 55-1550] Repository Directory C:/My_SoM_Project/Software/my_test/drivers doesn't exist in the disk

 

To me, it looks like SDK looks for the driver repository in my newly created project, instead of the SDK base directory (C:\Xilinx\SDK\2018.1\data\embeddedsw\XilinxProcessorIPLib\drivers)

 

Does anybody have a clue how to solve this problem?

 

Thanks

Simon

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
975 Views
Registered: ‎10-06-2016

Re: (XSDB Server)ERROR: [Hsi 55-1550] Repository Directory ".../drivers" doesn't exist in the disk

Jump to solution
Hi @richnsim,

The error message seems to be more related to some custom IP in your Vivado design which does not have any associated driver. Do you have any custom IP in your design?

Regards
Ibai

Ibai
Don’t forget to reply, kudo, and accept as solution.
2 Replies
Moderator
Moderator
976 Views
Registered: ‎10-06-2016

Re: (XSDB Server)ERROR: [Hsi 55-1550] Repository Directory ".../drivers" doesn't exist in the disk

Jump to solution
Hi @richnsim,

The error message seems to be more related to some custom IP in your Vivado design which does not have any associated driver. Do you have any custom IP in your design?

Regards
Ibai

Ibai
Don’t forget to reply, kudo, and accept as solution.
Observer richnsim
Observer
770 Views
Registered: ‎06-01-2018

Re: (XSDB Server)ERROR: [Hsi 55-1550] Repository Directory ".../drivers" doesn't exist in the disk

Jump to solution

Hi @ibaie

 

You are right. The problem was, that I created a custom IP using the Vivado "Create AXI4 Peripheral" tool.

This automatically adds some software driver files to the IP repository. By default, these files are referenced in the IP's "component.xml" file.

 

My problem was, that when committing to our GIT repository, I didn't add these driver files, because they didn't seem to be much of use. After cloning the repository to a new working location, the error I mentioned started to occur.

 

Meanwhile I found out, that this can be avoided when the "Software Driver" folder is removed from the "File Groups" list during packaging the IP.

 

Thanks for your help,

Simon