cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Observer
Observer
858 Views
Registered: ‎05-23-2017

[XSDK 2018.2] program_flash fails to open file

Hi,

 

I am trying to flash a custom zynqmp based HW using program_flash (XSDK 2018.2) through JTAG, which seemingly fails to open the file behind a symbolic link:

 

martin@dell:~/work/z7000-distro_sumo/build/tmp/deploy/images/nanomind-ultra-zu6eg-uv1$ file Image
Image: symbolic link to Image--4.14-xilinx-v2018.1+git0+15b23f7fa8-r0-nanomind-ultra-zu6eg-uv1-20180702053346.bin

 

martin@dell:~/work/z7000-distro_sumo/build/tmp/deploy/images/nanomind-ultra-zu6eg-uv1$ program_flash -f Image -offset 0x320000 -fsbl ~/Downloads/fsbl.elf -flash_type qspi_dual_parallel -verify -cable type xilinx_tcf url tcp:localhost:3121

****** Xilinx Program Flash
****** Program Flash v2018.2 (64-bit)
**** SW Build 2258646 on Thu Jun 14 20:02:38 MDT 2018
** Copyright 1986-2018 Xilinx, Inc. All Rights Reserved.


Connected to hw_server @ tcp:localhost:3121
Available targets and devices:
Target 0 : jsn-JTAG-HS3-210299A1F210
Device 0: jsn-JTAG-HS3-210299A1F210-24739093-0

Retrieving Flash info...

Initialization done, programming the memory

ERROR: Flash Operation Failed

 

However flashing the file behind the symbolic link seems to work:

 

martin@dell:~/work/z7000-distro_sumo/build/tmp/deploy/images/nanomind-ultra-zu6eg-uv1$ program_flash -f Image--4.14-xilinx-v2018.1+git0+15b23f7fa8-r0-nanomind-ultra-zu6eg-uv1-20180702053346.bin -offset 0x320000 -fsbl ~/Downloads/fsbl.elf -flash_type qspi_dual_parallel -verify -cable type xilinx_tcf url tcp:localhost:3121

****** Xilinx Program Flash
****** Program Flash v2018.2 (64-bit)
**** SW Build 2258646 on Thu Jun 14 20:02:38 MDT 2018
** Copyright 1986-2018 Xilinx, Inc. All Rights Reserved.


Connected to hw_server @ tcp:localhost:3121
Available targets and devices:
Target 0 : jsn-JTAG-HS3-210299A1F210
Device 0: jsn-JTAG-HS3-210299A1F210-24739093-0

Retrieving Flash info...

Initialization done, programming the memory
===== mrd->addr=0xFF5E0204, data=0x00000000 =====
BOOT_MODE REG = 0x0000
Downloading FSBL...
Running FSBL...
Finished running FSBL.


U-Boot 2018.01-00071-g0018654-dirty (May 01 2018 - 11:30:07 -0600)

Model: ZynqMP MINI QSPI
Board: Xilinx ZynqMP
DRAM: 256 KiB
EL Level: EL3
Using default environment

In: dcc
Out: dcc
Err: dcc
ZynqMP> sf probe 0 0 0
SF: Detected mt25ql02g with page size 512 Bytes, erase size 128 KiB, total 512 MiB
ZynqMP> Sector size = 131072.
f probe 0 0 0
Performing Erase Operation...
sf erase 320000 E00000
SF: 14680064 bytes @ 0x320000 Erased: OK
ZynqMP> Erase Operation successful.
INFO: [Xicom 50-44] Elapsed time = 1 sec.
Performing Program Operation...
0%...sf write FFFC0000 320000 20000

.

.

.

.

 

Host OS is Ubuntu 17.10. Other symbolic links (generated by Yocto) seems to work just fine.

 

Is this the right place for a bug report?

 

Martin

0 Kudos
Reply
3 Replies
Highlighted
Xilinx Employee
Xilinx Employee
802 Views
Registered: ‎10-06-2016

Hi @mnsgs

 

I just tested it from my side using a symbolik link to the boot image and it does work for me, so I think it's not an issue related to that fact. The only two reason I can figure out right now is either a corrupted symbolik link or issues with the hardware when you tried to test it.

 

Can you redo the testing?

 

Regards

Ibai


Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos
Reply
Highlighted
Observer
Observer
765 Views
Registered: ‎05-23-2017

Hi @ibaie,

 

Flashing files through symbolic links works in general, issue is specific for this particular link/file. As stated previously and below:

 

martin@dell:~/work/z7000-distro_sumo/build/tmp/deploy/images/nanomind-ultra-zu6eg-uv1$ file Image
Image: symbolic link to Image--4.14-xilinx-v2018.1+git0+15b23f7fa8-r0-nanomind-ultra-zu6eg-uv1-20180702053346.bin
martin@dell:~/work/z7000-distro_sumo/build/tmp/deploy/images/nanomind-ultra-zu6eg-uv1$ ls -laH Image
-rw-r--r-- 2 martin martin 14608896 Jul 2 08:06 Image

 

the link seems to be fine. I tried multiple combinations of file/link names but encounter the same issue nevertheless. 

 

As discussed in the other thread I can provide the artifacts for you to reproduce.

 

Thanks,

Martin

0 Kudos
Reply
Highlighted
Observer
Observer
594 Views
Registered: ‎05-23-2017

Hi @ibaie,

 

Any update on the topic:

 

1) Did you receive the provided artifacts?

2) Did you manage to reproduce the issue?

3) Can we expect it resolved in 2018.3?

 

Thanks,

Martin

0 Kudos
Reply