cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
EmbeddedMan
Visitor
Visitor
110 Views
Registered: ‎03-11-2021

XSDK can't find libxil.a

Hi my helpers :),

I recovered a project from a former coworker, it's a C application for a Zynq Ultrascale SoC with Cortex A9. I tried with many difficulties to install Vivado Suite 2019.2 and XSDK 2017.4 on a Linux machine and now I'm trying to build the application as it worked a few month ago (no changes from my side).

The building process stands for bsp, fsbl and the application, each time I've an error on -lxil:

Building target: XMC_fsbl.elf
Invoking: ARM v7 gcc linker
arm-none-eabi-gcc -mcpu=cortex-a9 -mfpu=vfpv3 -mfloat-abi=hard -Wl,-build-id=none -specs=Xilinx.spec -Wl,-T -Wl,../src/lscript.ld -L../../XMC_bsp/ps7_cortexa9_0/lib -o "XMC_fsbl.elf"  ./src/fsbl_handoff.o ./src/fsbl_hooks.o ./src/image_mover.o ./src/main.o ./src/md5.o ./src/nand.o ./src/nor.o ./src/pcap.o ./src/ps7_init.o ./src/qspi.o ./src/rsa.o ./src/sd.o   -Wl,--start-group,-lxil,-lgcc,-lc,--end-group -Wl,--start-group,-lxilffs,-lxil,-lgcc,-lc,--end-group
/opt/Xilinx/SDK/2017.4/gnu/aarch32/lin/gcc-arm-none-eabi/bin/../lib/gcc/arm-none-eabi/6.2.1/../../../../arm-none-eabi/bin/ld : ne peut trouver -lxil
collect2: error: ld returned 1 exit status
make: *** [makefile:41 : XMC_fsbl.elf] Erreur 1
[ERROR]  : Can't read file - XMC_fsbl/Debug/XMC_fsbl.elf

If I get well, this is about libxil.a that the linker wants to find in "XMC_bsp/ps7_cortexa9_0/lib" but that lib directory is nor there neither in "arm_none_eabi/bin/ld", I searched for this libxil.a in my entire laptop, I only found it in "opt/Xilinx/SDK/2017.4/gnu/microblaze/lin/microblaze-xilinx-elf/sysroot/lib"....

I don't get it why I've only microblaze lib installed even though I confirmed to work with cortex during SDK installation.

Thank for your help.

0 Kudos
0 Replies