UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer wpmoorenasa
Observer
151 Views
Registered: ‎05-08-2019

XSDK deletes linker flags when opening from command line vs. Opening from Vivado.

??Why?? are my linker flags getting lost when I open XSDK from the command line:

    $ xsdk -workspace myproject.sdk &

    arm-none-eabi-g++  is  missing: ... -Wl,--start-group,-lxil,-llwip4,-lgcc,-lc,--end-group

Verses open xsdk from vivado:

   $ vivado  & #. then click around in menu: File->open sdk... or some such #$@#...

   arm-none-eabi-g++  NOT missing: ... -Wl,--start-group,-lxil,-llwip4,-lgcc,-lc,--end-group

 

Xilinx Tool version: 2017.3

 

0 Kudos
1 Reply
Moderator
Moderator
96 Views
Registered: ‎10-06-2016

Re: XSDK deletes linker flags when opening from command line vs. Opening from Vivado.

Hi @wpmoorenasa 

Could you provide more details on how to reproduce this issue? I mean, it seems you have an application project and the BSP with LWIP libary enabled, and the linker flags missing in your Makefile only applies to the application, am I right? Again bit more details might help to understand better the issue and figure out what's going on.

Regards


Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos