cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
karvi_in
Observer
Observer
6,093 Views
Registered: ‎11-14-2009

Xilinx EDK XPS stalls while generating bitstream

Jump to solution

Hi,

 

   I am trying to compile the basic peripheral test app on a Digilent Nexys 2 board with a Spartan  3E FPGA on Vista 32bit. I am on the administrator account.

 

   I get the following last few console lines

 

 

Running Xilinx Implementation tools..
*********************************************

   xflow -wd implementation -p xc3s500efg320-4 -implement xflow.opt -ise ../__xps/ise/system.ise system.ngc
Release 11.1 - Xflow L.33 (nt)
Copyright (c) 1995-2009 Xilinx, Inc.  All rights reserved.
xflow.exe -wd implementation -p xc3s500efg320-4 -implement xflow.opt -ise
../__xps/ise/system.ise system.ngc 
PMSPEC -- Overriding Xilinx file <C:/Xilinx/11.1/EDK/spartan3/data/spartan3.acd>
with local file <c:/Xilinx/11.1/ISE/spartan3/data/spartan3.acd>
.... Copying flowfile c:/Xilinx/11.1/ISE/xilinx/data/fpga.flw into working
directory G:/Electronics/FPGA/EDK_Projects/Test1/implementation

Using Flow File: G:/Electronics/FPGA/EDK_Projects/Test1/implementation/fpga.flw
 
Using Option File(s):
 G:/Electronics/FPGA/EDK_Projects/Test1/implementation/xflow.opt  

 

 

 

 

 It seems to stall right after this. The process progress indicator continues animation, but there is no CPU activity for XPS. 

 

I kindly request someone to help me out. 

 

Thanks and Regards,

 

Karthik

0 Kudos
1 Solution

Accepted Solutions
karvi_in
Observer
Observer
7,552 Views
Registered: ‎11-14-2009

Solved! Seems to be an acess rights problem. It works from a thumb drive; a related solution i found on this forum. If I copy the project folder back to the hard drive and use "Update Bitstream", it7 still works.

 

I have only the Xilinx Cygwin. I might upgrade to Windows 7 and see if its better. 

View solution in original post

0 Kudos
4 Replies
karvi_in
Observer
Observer
7,553 Views
Registered: ‎11-14-2009

Solved! Seems to be an acess rights problem. It works from a thumb drive; a related solution i found on this forum. If I copy the project folder back to the hard drive and use "Update Bitstream", it7 still works.

 

I have only the Xilinx Cygwin. I might upgrade to Windows 7 and see if its better. 

View solution in original post

0 Kudos
Anonymous
Not applicable
5,363 Views

Hi!

 

I've got the same problem on Windows 7 but still cannot solve it.

Could you tell me more details about what exactly you have done?

0 Kudos
karvi_in
Observer
Observer
5,351 Views
Registered: ‎11-14-2009

Sorry, its been a while since I had this prob and I dont remember this very well. But I believe starting Xilinx as an administrator fixed the problem.There is a similar post on this forum which might help you.

 

 

0 Kudos
xiaofeip_dup
Xilinx Employee
Xilinx Employee
5,189 Views
Registered: ‎08-07-2007

 

Please check out AR35351, http://www.xilinx.com/support/answers/35351.htm.

 

Regards,

Felix

0 Kudos