UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor smartic
Visitor
5,060 Views
Registered: ‎09-14-2012

Xilinx SDK 14.1 Build ucosii source code error? cannot find -lxil

PC Host OS: Win7 64-bit

ISE:ISE 14.1

Target:Build ucosii for Zynq XC7Z020

Build message:

Building target: ucos-ii_demo_0.elf
Invoking: ARM gcc linker
arm-xilinx-eabi-gcc -Wl,-T -Wl,../src/lscript.ld -L../../ucos-ii_demo_bsp_0/ps7_cortexa9_0/lib -o"ucos-ii_demo_0.elf" ./src/uCOS-II/Source/os_core.o ./src/uCOS-II/Source/os_dbg_r.o ./src/uCOS-II/Source/os_flag.o ./src/uCOS-II/Source/os_mbox.o ./src/uCOS-II/Source/os_mem.o ./src/uCOS-II/Source/os_mutex.o ./src/uCOS-II/Source/os_q.o ./src/uCOS-II/Source/os_sem.o ./src/uCOS-II/Source/os_task.o ./src/uCOS-II/Source/os_time.o ./src/uCOS-II/Source/os_tmr.o ./src/uCOS-II/Ports/ARM-Cortex-A9/Generic/GNU/os_cpu_a.o ./src/uCOS-II/Ports/ARM-Cortex-A9/Generic/GNU/os_cpu_c.o ./src/uCOS-II/Ports/ARM-Cortex-A9/CSP/Xilinx/Cortex-A9_MPCore/os_csp.o ./src/uC-LIB/lib_ascii.o ./src/uC-LIB/lib_math.o ./src/uC-LIB/lib_mem.o ./src/uC-LIB/lib_str.o ./src/uC-CSP/MCU/csp.o ./src/uC-CSP/MCU/Xilinx/Cortex-A9_MPCore/csp_gpio.o ./src/uC-CSP/MCU/Xilinx/Cortex-A9_MPCore/csp_int.o ./src/uC-CSP/MCU/Xilinx/Cortex-A9_MPCore/csp_pm.o ./src/uC-CSP/MCU/Xilinx/Cortex-A9_MPCore/csp_tmr.o ./src/uC-CPU/cpu_core.o ./src/uC-CPU/ARM-Cortex-A9/GNU/cpu_a.o ./src/Init/platform.o ./src/BSP/bsp.o ./src/BSP/bsp_os.o ./src/App/app.o ./src/App/app_hooks.o -Wl,--start-group,-lxil,-lgcc,-lc,--end-group
c:/xilinx141/14.1/ise_ds/edk/gnu/arm/nt64/bin/../lib/gcc/arm-xilinx-eabi/4.6.1/../../../../arm-xilinx-eabi/bin/ld.exe: cannot find -lxil
collect2: ld returned 1 exit status
make: *** [ucos-ii_demo_0.elf] error 1

 

How to do ?

Thanks.

 

0 Kudos
2 Replies
Visitor davewills
Visitor
4,928 Views
Registered: ‎10-15-2012

Re: Xilinx SDK 14.1 Build ucosii source code error? cannot find -lxil

Smartic,

 

Did you ever resolve this?  I'm stuck trying to get Micrium's OS-II running and am getting the "cannot find -lxil" error.

 

I'm completely new to this environment and got this the first day.  I found a link that said pathnames couldn't have spaces.  Fixed that, problem went away.  Now I have no spaces and the problem is back with a new project.

 

I'm baffled.

 

Thanks,

 

Dave

0 Kudos
Visitor cdpalmer3
Visitor
4,817 Views
Registered: ‎12-03-2012

Re: Xilinx SDK 14.1 Build ucosii source code error? cannot find -lxil

ditto... Same issue. My guess is a bad path to project somewhere, but have not found it yet. Anyone figure this out?

 

Building target: axi_vdma_display.elf

Invoking: ARM gcc linker

arm-xilinx-eabi-gcc -Wl,-T -Wl,../src/lscript.ld -LC:/test_820/SW/SDK_Workspace/standalone_bsp_0/ps7_cortexa9_0/lib -o"axi_vdma_display.elf"  ./src/axi_display.o ./src/axipmon.o ./src/ivk_osd.o ./src/ivk_video_resolution.o ./src/platform.o ./src/xtpg_app.o ./src/zc702_i2c_utils.o   -lm -Wl,--start-group,-lxil,-lgcc,-lc,--end-group

c:/xilinx/14.3/ise_ds/edk/gnu/arm/nt64/bin/../lib/gcc/arm-xilinx-eabi/4.6.1/../../../../arm-xilinx-eabi/bin/ld.exe: cannot find -lxil

collect2: ld returned 1 exit status

make: *** [axi_vdma_display.elf] Error 1

0 Kudos