cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jrp
Explorer
Explorer
710 Views
Registered: ‎01-24-2018

Xilinx SDK 2017.3 - File opens in gedit

I have a project that I have been using for a long time.

While in the SDK this morning, I noticed that when I tried

to open one particular source file, it did not appear in the SDK editor window.

Instead, the file popped open in gedit???

I cannot find why only this file does this. All of the other files in the project open in the editor window

of the SDK, this is the only file that does this.

 

How do I make it stop opening this one file in gedit please?

 

0 Kudos
3 Replies
jrp
Explorer
Explorer
704 Views
Registered: ‎01-24-2018

Found the problem.

Right mouse click on file and change the "open with" setting.

Doh!

0 Kudos
ibaie
Xilinx Employee
Xilinx Employee
659 Views
Registered: ‎10-06-2016

Hi @jrp,

You are right, the easy way to get it work is using "open with" menu context. Under the hood this will just create a new entry in the File Associations property in the SDK preferences a shown in the bellow image.

i.e. add a rule to open .c files with Notepad++

image.png

 

Regards


Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos
jrp
Explorer
Explorer
646 Views
Registered: ‎01-24-2018

Re: "You are right, the easy way to get it work"

I have done a very bad job explaining my problem or you

have just missed my point. I -do not- want to poen

the file with an external editor, nor could I figure out why it was doing so.

My question was supposed to be.... how do I stop it from opening

it in an external editor.

0 Kudos