UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor sysseon
Visitor
8,109 Views
Registered: ‎03-10-2014

Xilinx SDK - Error building BSP

Jump to solution

Hi,

 

I'm sorry if that's a stupid question, but I'm stuck. I'm working with Xilinx SDK, but yesterday it suddenly started giving errors while building my projects. The problem seem to be related to BSP built. After looking for a solution with no luck, I decided to uninstall Vivado + Xilinx SDK and in passing I upgraded to 2014.2 version, but still no luck. Suggestions?

 

That is the error:

make: *** [ps7_cortexa9_0/libsrc/...........] Error 5

 

Error 5.png

 

Thank you so much.

 

Sysseon

0 Kudos
1 Solution

Accepted Solutions
Visitor sysseon
Visitor
7,344 Views
Registered: ‎03-10-2014

Re: Xilinx SDK - Error building BSP

Jump to solution

Thanks Norman. Yes, it was a Temp directory problem, more precisely a privileges problem.

 

I found the answer in the Microsoft Community forum. I hope is not a problem to paste it here (my English is not very good, so it would take a time for me to explain).

 

 ------------------------------------------------------------------------------

" Answer by Moogles:

 

The problem is with the security permissions on your profile temp folder. To fix it navigate to %temp% or C:\Users\[Username]\AppData\Local and right click on the Temp folder and choose properties, then click the security tab and click advanced.

 

On the permissions tab you should see the permissions that are there. There should 3 which are:

'SYSTEM' with Full control which applies to 'This folder, subfolders and files'

'Administrators' with Full control which applies to 'This folder, subfolders and files'

'Your Username' with Full control which applies to 'This folder, subfolders and files'

 

and all 3 should be inherited from the C:\Users\[Username]\ folder.

If you don't have the 'Include inheritable permissions from this object's parent' option ticked, then tick it and click continue if there are any problems, then remove the permissions that aren't inherited.

Once you click 'Apply' and click 'OK' you should have the permissions to write to the directory and you won't get those error messages any more."

 ------------------------------------------------------------------------------

 

So, problem solved! Thank you for your help!

Sysseon

0 Kudos
13 Replies
Xilinx Employee
Xilinx Employee
8,100 Views
Registered: ‎08-02-2007

Re: Xilinx SDK - Error building BSP

Jump to solution

Hi,

 

Is this a BSP that is being updated or built from scratch? 

 

Would that be possible to attach the bsp.log?

 

--Hem

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Visitor sysseon
Visitor
8,098 Views
Registered: ‎03-10-2014

Re: Xilinx SDK - Error building BSP

Jump to solution

The problem appeared when I was working with a project that used that BSP, but I didn't modified it. After that, I've created new BSPs from scratch, but the problem persists. As I said, I even reinstalled all software.

I attach the bsp.log. Thank you for the help!

0 Kudos
Xilinx Employee
Xilinx Employee
8,088 Views
Registered: ‎07-01-2010

Re: Xilinx SDK - Error building BSP

Jump to solution
Hi,

I have seen a similar issue in 2014.1.
Can you try Inserting a line "set LIB=" at the top of the XSDK.bat file?

The XSDK.bat file is available in the install location SDK\2014.2\bin

Close SDK and reopen it once the changes are made.

Please let me know if this helps.

Regards,
Achutha
---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------
0 Kudos
Visitor sysseon
Visitor
8,072 Views
Registered: ‎03-10-2014

Re: Xilinx SDK - Error building BSP

Jump to solution

Hi,

 

Thanks for the help, but the problem persists. I attach my 'xsdk.bat' in case it could be the source of the errors. Now I have only 2014.2 version installed. However, before that, I had the same error with 2013.3 and 2014.1 (both of them installed, but the problem appeared when working with 2014.1).

 

Thanks again.

Sysseon

0 Kudos
Scholar norman_wong
Scholar
8,045 Views
Registered: ‎05-28-2012

Re: Xilinx SDK - Error building BSP

Jump to solution

The error in your bsp.log is:

process_begin: CreateProcess(C:\Users\Noessys\AppData\Local\Temp\make5580-1.bat, C:\Users\Noessys\AppData\Local\Temp\make5580-1.bat, ...) failed.
make (e=5): Acceso denegado.

In English:

make (e=5): Access is denied.

A bit of Google and most sites would suggest you have multiple "makes" with your PATH. I think you are invoking a "make" with no privilege. Try the windows command "where" (equivalent to linux "which):

where *make*.*

 

0 Kudos
Visitor sysseon
Visitor
8,035 Views
Registered: ‎03-10-2014

Re: Xilinx SDK - Error building BSP

Jump to solution

Ok, thanks. I've googled, but I don't understand which "make" I should use. If I execute command

 

where *make*.*

 

I get

 

C:\Windows\System32\makecab.exe

 

Is that correct? Should I remove any path from my PATH environment variable? I'm very sorry to be boring, but I've never understood this compilers issue.

 

Thanks again.

0 Kudos
Scholar norman_wong
Scholar
8,024 Views
Registered: ‎05-28-2012

Re: Xilinx SDK - Error building BSP

Jump to solution

I spoke too soon on the "where" command. I got the same results. I think Xilinx SDK sets up it's own paths inside it's own command shells. A quick search of the my Xilinx directory gives only 2:

 

14.7\ISE_DS\EDK\gnu\MinGW\Beta\nt64\bin\make.exe

14.7\ISE_DS\EDK\gnu\gnuwin\bin\make.exe

 

No idea which one is used. Eclipse and Xilinx do hide details. My bsp.log looks nothing like yours. I assume 2014.2 Vivado is much different than 14.7 ISE. No XDSK.BAT her either. Sorry about that. Red herring.

0 Kudos
Visitor sysseon
Visitor
8,010 Views
Registered: ‎03-10-2014

Re: Xilinx SDK - Error building BSP

Jump to solution

In my Xilinx directory there are only two makes:

 

C:\Xilinx\SDK\2014.2\gnu\arm\nt\bin\cs-make.exe

C:\Xilinx\SDK\2014.2\gnuwin\bin\make.exe

 

In case one of them is the correct make for Xilinx SDK, how could I do Xilinx to use it? If that is a privileges issue, how could I fix it? I'm sorry, but I'm really stuck these days with this problem...

 

Thank you.
Sysseon

0 Kudos
Scholar norman_wong
Scholar
8,000 Views
Registered: ‎05-28-2012

Re: Xilinx SDK - Error building BSP

Jump to solution

A bit more Googling and reading and I would guess that it is not "make" but what "make" is trying to start. In your attached bsp log, something is objecting to this file.

 

C:\Users\Noessys\AppData\Local\Temp\make5580-1.bat

 

Perhaps try a closing all apps and emptying the Temp directory.

0 Kudos
Visitor sysseon
Visitor
7,345 Views
Registered: ‎03-10-2014

Re: Xilinx SDK - Error building BSP

Jump to solution

Thanks Norman. Yes, it was a Temp directory problem, more precisely a privileges problem.

 

I found the answer in the Microsoft Community forum. I hope is not a problem to paste it here (my English is not very good, so it would take a time for me to explain).

 

 ------------------------------------------------------------------------------

" Answer by Moogles:

 

The problem is with the security permissions on your profile temp folder. To fix it navigate to %temp% or C:\Users\[Username]\AppData\Local and right click on the Temp folder and choose properties, then click the security tab and click advanced.

 

On the permissions tab you should see the permissions that are there. There should 3 which are:

'SYSTEM' with Full control which applies to 'This folder, subfolders and files'

'Administrators' with Full control which applies to 'This folder, subfolders and files'

'Your Username' with Full control which applies to 'This folder, subfolders and files'

 

and all 3 should be inherited from the C:\Users\[Username]\ folder.

If you don't have the 'Include inheritable permissions from this object's parent' option ticked, then tick it and click continue if there are any problems, then remove the permissions that aren't inherited.

Once you click 'Apply' and click 'OK' you should have the permissions to write to the directory and you won't get those error messages any more."

 ------------------------------------------------------------------------------

 

So, problem solved! Thank you for your help!

Sysseon

0 Kudos
Scholar norman_wong
Scholar
3,439 Views
Registered: ‎05-28-2012

Re: Xilinx SDK - Error building BSP

Jump to solution

That's good news. Thanks for posting your solution. This will come in handy if I or others encounter the same problem. Makes me wonder how the permissions got changed in the first place.

 

Please mark your post as solved.

0 Kudos
Contributor
Contributor
2,025 Views
Registered: ‎11-15-2007

Re: Xilinx SDK - Error building BSP

Jump to solution

Hello All,

 

I'm going through the Zybno tutorial, lab1.

http://www.xilinx.com/support/university/vivado/vivado-workshops/Vivado-embedded-design-flow-zynq.html

 

When I move on to the SDK section I get the following error when building the bsp.

make: *** [ps7_cortexa9_0/libsrc/coresightps_dcc_v1_2/src/make.libs] Error 2    mem_test_bsp

 

I'm not editing anything. The OS is Centos 7.2. Vivado 2015.4(64-bit) I tried the methods mentioned above but got the following response

 

sudo yum install libselinux1:i386
[sudo] password for <username>:
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror.5ninesolutions.com
 * epel: mirror.unl.edu
 * extras: mirror.5ninesolutions.com
 * updates: mirror.5ninesolutions.com
No package libselinux1:i386 available.
Error: Nothing to do

 

Where are we supporsed to edit the path? In the Makefile? or the system's $PATH? I'm attaching the Makefile from my mem_test_bps folder.

 

I didn't get any errors or warnings while installing.

 

Any suggestions?

 

Thank you,

Sudhanshu

0 Kudos
Contributor
Contributor
2,008 Views
Registered: ‎11-15-2007

Re: Xilinx SDK - Error building BSP

Jump to solution
I figured it out.

I'm using Centos 7.2 so there seems to be a library issue.
Solution is
sudo yum install libselinux.i686

You may later face the issue of the programming cable not working so just try
sudo -s
source /opt/Xilinx/SDK/2015.4/data/xicom/cable_drivers/lin64/install_script/install_drivers/install_digilent.sh

Last step is in case you are using Zybo RevB like me.
0 Kudos