cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
raffa1993
Visitor
Visitor
489 Views
Registered: ‎06-18-2019

Zynq 7000 SD card boot image issue

Dear All,

My name is Raffaele, I'm an Embedded Engineer.

I've been working for a couple of months with the Zynq 7000, using a custom board: while debugging with JTAG or booting via QSPI both work perfectly, but I still cannot boot through the SD Card.

Now I've created a simple workspace with a Hardware Platform Specification, a Board Support Package, an FSBL and an application that simply print out on the Serial Port an "hello world" message: I've successfully run it with JTAG and I've also created a bootable image inside the QSPI.

When I create the "boot.bin" file for the SD Card and I try to boot via SD Card, nothing happens.

The hardware around SD boot has been properly verified with a "boot.bin" sample, so I suppose that the problem could be in the configuration of the boot image.

Can anybody help me?

Thanks in advance,
Raffaele

0 Kudos
1 Reply
timothyv
Xilinx Employee
Xilinx Employee
387 Views
Registered: ‎07-11-2019

Hello @raffa1993 

To start, I would like to point you to a previous Answer Record that deals with Zynq 7000 SD Programming/Booting Cecklist. I believe this may help in trying to debug. I have also attached a forum question that is very close to what you are trying to do. 

I hope this helps!

AR: https://www.xilinx.com/support/answers/59476.html

Forum: https://forums.xilinx.com/t5/Other-FPGA-Architecture/How-to-make-bootable-SD-card-for-Zynq-7000-series-PL-only/td-p/876083

-------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------------------------------

0 Kudos